summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author David Woodfall2010-10-17 16:01:09 +0200
committer Robby Workman2010-10-18 03:16:51 +0200
commitda960f0a23721d7804a29d255c068a333e28c85a (patch)
tree7e561e49fd1c38aa843b4370a795268abc6b01a6 /libraries
parent8de073c00593ffd241cab85b600a015d1af1d6c9 (diff)
downloadslackbuilds-da960f0a23721d7804a29d255c068a333e28c85a.tar.gz
libraries/PyYAML: Renamed and updated for version 3.09.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/PyYAML/PyYAML.SlackBuild86
-rw-r--r--libraries/PyYAML/PyYAML.info10
-rw-r--r--libraries/PyYAML/README6
-rw-r--r--libraries/PyYAML/slack-desc20
4 files changed, 122 insertions, 0 deletions
diff --git a/libraries/PyYAML/PyYAML.SlackBuild b/libraries/PyYAML/PyYAML.SlackBuild
new file mode 100644
index 0000000000..ff8146424d
--- /dev/null
+++ b/libraries/PyYAML/PyYAML.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-PyYAML
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PyYAML
+VERSION=${VERSION:-3.09}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGES LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/PyYAML/PyYAML.info b/libraries/PyYAML/PyYAML.info
new file mode 100644
index 0000000000..0129e0a7a5
--- /dev/null
+++ b/libraries/PyYAML/PyYAML.info
@@ -0,0 +1,10 @@
+PRGNAM="PyYAML"
+VERSION="3.09"
+HOMEPAGE="http://pyyaml.org"
+DOWNLOAD="http://pyyaml.org/download/pyyaml/PyYAML-3.09.tar.gz"
+MD5SUM="f219af2361e87fdc5e85e95b84c11d87"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="dsomero"
diff --git a/libraries/PyYAML/README b/libraries/PyYAML/README
new file mode 100644
index 0000000000..8e4d5959ce
--- /dev/null
+++ b/libraries/PyYAML/README
@@ -0,0 +1,6 @@
+pyyaml (YAML parser and emitter for Python)
+
+YAML is a data serialization format designed for human readability
+and interaction with scripting languages. PyYAML is a YAML parser and
+emitter for Python.
+
diff --git a/libraries/PyYAML/slack-desc b/libraries/PyYAML/slack-desc
new file mode 100644
index 0000000000..b5a48cf811
--- /dev/null
+++ b/libraries/PyYAML/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+PyYAML: PyYAML (YAML parser and emitter for Python)
+PyYAML:
+PyYAML: YAML is a data serialization format designed for human readability
+PyYAML: and interaction with scripting languages. PyYAML is a YAML parser
+PyYAML: and emitter for Python.
+PyYAML:
+PyYAML: Homepage: http://pyyaml.org
+PyYAML:
+PyYAML:
+PyYAML:
+PyYAML:
+