summaryrefslogtreecommitdiffstats
path: root/libraries/zope.hookable
diff options
context:
space:
mode:
author Mikko Värri2010-08-14 22:27:38 +0200
committer Erik Hanson2010-08-15 02:04:52 +0200
commit8fd56589b5eb6a7ea2f4019591db2d552062f690 (patch)
treef1800aafaaaae5da30c085b3801a006e0ddbb30f /libraries/zope.hookable
parent22b8a9aafe59502febcb62f33d063c5b00ad5013 (diff)
downloadslackbuilds-8fd56589b5eb6a7ea2f4019591db2d552062f690.tar.gz
libraries/zope.hookable: Added (Hookable object support)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries/zope.hookable')
-rw-r--r--libraries/zope.hookable/README7
-rw-r--r--libraries/zope.hookable/slack-desc19
-rw-r--r--libraries/zope.hookable/zope.hookable.SlackBuild54
-rw-r--r--libraries/zope.hookable/zope.hookable.info10
4 files changed, 90 insertions, 0 deletions
diff --git a/libraries/zope.hookable/README b/libraries/zope.hookable/README
new file mode 100644
index 0000000000..37f53eab94
--- /dev/null
+++ b/libraries/zope.hookable/README
@@ -0,0 +1,7 @@
+zope.hookable (Hookable object support)
+
+Support the efficient creation of hookable objects, which are
+callable objects that are meant to be replaced by other callables,
+at least optionally.
+
+To build, this requires pysetuptools.
diff --git a/libraries/zope.hookable/slack-desc b/libraries/zope.hookable/slack-desc
new file mode 100644
index 0000000000..9d9039b466
--- /dev/null
+++ b/libraries/zope.hookable/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+zope.hookable: zope.hookable (Hookable object support)
+zope.hookable:
+zope.hookable: Support the efficient creation of hookable objects, which are
+zope.hookable: callable objects that are meant to be replaced by other callables,
+zope.hookable: at least optionally.
+zope.hookable:
+zope.hookable:
+zope.hookable:
+zope.hookable:
+zope.hookable:
+zope.hookable:
diff --git a/libraries/zope.hookable/zope.hookable.SlackBuild b/libraries/zope.hookable/zope.hookable.SlackBuild
new file mode 100644
index 0000000000..2189f8b13b
--- /dev/null
+++ b/libraries/zope.hookable/zope.hookable.SlackBuild
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+# Slackware build script for zope.hookable
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=zope.hookable
+VERSION=${VERSION:-3.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.txt README.txt PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/zope.hookable/zope.hookable.info b/libraries/zope.hookable/zope.hookable.info
new file mode 100644
index 0000000000..c133ba5461
--- /dev/null
+++ b/libraries/zope.hookable/zope.hookable.info
@@ -0,0 +1,10 @@
+PRGNAM="zope.hookable"
+VERSION="3.4.1"
+HOMEPAGE="http://pypi.python.org/pypi/zope.hookable"
+DOWNLOAD="http://pypi.python.org/packages/source/z/zope.hookable/zope.hookable-3.4.1.tar.gz"
+MD5SUM="fe6713aef5b6c0f4963fb984bf326da0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"