summaryrefslogtreecommitdiffstats
path: root/libraries/wxPython4
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2018-04-03 00:52:34 +0200
committer Willy Sudiarto Raharjo2018-04-07 03:13:10 +0200
commit696b43074569901a2e2d239112a47223657088f5 (patch)
tree18e9f57fd6f0644e4ec8357905faa21443707b04 /libraries/wxPython4
parent5939df3025359fcfb4f59732fa51c518ae514b5f (diff)
downloadslackbuilds-696b43074569901a2e2d239112a47223657088f5.tar.gz
libraries/wxPython4: Added (Crossplatform GUI Toolkit).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/wxPython4')
-rw-r--r--libraries/wxPython4/README17
-rw-r--r--libraries/wxPython4/doinst.sh9
-rw-r--r--libraries/wxPython4/slack-desc19
-rw-r--r--libraries/wxPython4/wxPython4.SlackBuild98
-rw-r--r--libraries/wxPython4/wxPython4.info10
5 files changed, 153 insertions, 0 deletions
diff --git a/libraries/wxPython4/README b/libraries/wxPython4/README
new file mode 100644
index 0000000000..aa28a3c0c7
--- /dev/null
+++ b/libraries/wxPython4/README
@@ -0,0 +1,17 @@
+wxPython4 (Crossplatform GUI Toolkit)
+
+wxPython is a cross-platform GUI toolkit for the Python programming language.
+It allows Python programmers to create programs with a robust, highly
+functional graphical user interface, simply and easily.
+
+It is implemented as a set of Python extension modules that wrap the GUI
+components of the popular wxWidgets cross platform library, which is written
+in C++.
+
+wxPython is a cross-platform toolkit. This means that the same program will
+run on multiple platforms without modification.
+
+Currently Supported platforms are Microsoft Windows, Mac OS X and macOS,
+and Linux or other unix-like systems with GTK2 or GTK3 libraries.
+In most cases the native widgets are used on each platform to provide
+a 100% native look and feel for the application.
diff --git a/libraries/wxPython4/doinst.sh b/libraries/wxPython4/doinst.sh
new file mode 100644
index 0000000000..65c7e2eeb9
--- /dev/null
+++ b/libraries/wxPython4/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/libraries/wxPython4/slack-desc b/libraries/wxPython4/slack-desc
new file mode 100644
index 0000000000..78bda04c28
--- /dev/null
+++ b/libraries/wxPython4/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+wxPython4: wxPython4 (Crossplatform GUI Toolkit)
+wxPython4:
+wxPython4: wxPython is a GUI toolkit for the Python programming language.
+wxPython4: It allows Python programmers to create programs with a robust,
+wxPython4: highly functional graphical user interface simply and easily.
+wxPython4: It is implemented as a Python extension module (native code)
+wxPython4: that wraps the popular wxWidgets cross platform GUI library
+wxPython4: which is written in C++.
+wxPython4:
+wxPython4: Homepage: https://wxPython.org/
+wxPython4:
diff --git a/libraries/wxPython4/wxPython4.SlackBuild b/libraries/wxPython4/wxPython4.SlackBuild
new file mode 100644
index 0000000000..6ea2cb14a0
--- /dev/null
+++ b/libraries/wxPython4/wxPython4.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for wxPython4
+
+# Copyright 2018 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Big thanks to Rich Shepard and Christoph Willing for the discussion on LQ
+#
+
+PRGNAM=wxPython4
+SRCNAM=wxPython
+VERSION=${VERSION:-4.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/share/{applications,pixmaps} $PKG/usr/share/icons/hicolor/{16x16,32x32}/apps
+install -m 644 wx/py/PyCrust_16.png $PKG/usr/share/icons/hicolor/16x16/apps/PyCrust.png
+install -m 644 wx/py/PyCrust_32.png $PKG/usr/share/icons/hicolor/32x32/apps/PyCrust.png
+ln -s /usr/share/icons/hicolor/32x32/apps/PyCrust.png $PKG/usr/share/pixmaps/PyCrust.png
+install -m 644 wx/py/PySlices_16.png $PKG/usr/share/icons/hicolor/16x16/apps/PySlices.png
+install -m 644 wx/py/PySlices_32.png $PKG/usr/share/icons/hicolor/32x32/apps/PySlices.png
+ln -s /usr/share/icons/hicolor/32x32/apps/PySlices.png $PKG/usr/share/pixmaps/PySlices.png
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wxPython
+cp -a *.rst LICENSE.txt docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/wxPython4/wxPython4.info b/libraries/wxPython4/wxPython4.info
new file mode 100644
index 0000000000..30a2898fdf
--- /dev/null
+++ b/libraries/wxPython4/wxPython4.info
@@ -0,0 +1,10 @@
+PRGNAM="wxPython4"
+VERSION="4.0.1"
+HOMEPAGE="https://wxPython.org/"
+DOWNLOAD="https://github.com/wxWidgets/Phoenix/releases/download/wxPython-4.0.1/wxPython-4.0.1.tar.gz"
+MD5SUM="a56ece3363da3949dd0f30c45cc21631"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 webkit2gtk"
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"