summaryrefslogtreecommitdiffstats
path: root/libraries/tlsh
diff options
context:
space:
mode:
author David Spencer2016-12-29 02:40:53 +0100
committer Willy Sudiarto Raharjo2016-12-31 02:22:12 +0100
commite8e323bd5ac350e95761d09a7125ed036fc97085 (patch)
tree0c16cc82305efa1a11785b4046e5dba72a433d44 /libraries/tlsh
parent6e6ba4276354fbbf0f44a27707a8eaa7be4f25d5 (diff)
downloadslackbuilds-e8e323bd5ac350e95761d09a7125ed036fc97085.tar.gz
libraries/tlsh: Added (fuzzy matching library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/tlsh')
-rw-r--r--libraries/tlsh/README10
-rw-r--r--libraries/tlsh/install-libraries.patch23
-rw-r--r--libraries/tlsh/slack-desc19
-rw-r--r--libraries/tlsh/tlsh.SlackBuild110
-rw-r--r--libraries/tlsh/tlsh.info10
5 files changed, 172 insertions, 0 deletions
diff --git a/libraries/tlsh/README b/libraries/tlsh/README
new file mode 100644
index 0000000000..d4e28dd8b5
--- /dev/null
+++ b/libraries/tlsh/README
@@ -0,0 +1,10 @@
+TLSH is a fuzzy matching library. Given a byte stream with a minimum
+length of 256 bytes, TLSH generates a hash value which can be used for
+similarity comparisons.
+
+("TLSH" stands for Trend Micro Locality Sensitive Hash.)
+
+python3 is an optional dependency. You need to set PYTHON3=yes,
+for example:
+
+ PYTHON3=yes ./python-libarchive-c.SlackBuild
diff --git a/libraries/tlsh/install-libraries.patch b/libraries/tlsh/install-libraries.patch
new file mode 100644
index 0000000000..83f9c6cae5
--- /dev/null
+++ b/libraries/tlsh/install-libraries.patch
@@ -0,0 +1,23 @@
+From fb71fc45992a9adf73b3c8194bdd691391ca34d7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=C3=A9r=C3=A9my=20Bobbio?= <lunar@debian.org>
+Date: Wed, 27 Jan 2016 17:44:06 +0100
+Subject: [PATCH] install the library in expected directories
+
+We add CMake install directives in order to see the library files installed in
+the expected multiarch compatible locations.
+---
+ src/CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index b1c92fb..c8d3fd9 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -21,3 +21,7 @@ set_target_properties(tlsh_shared PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_SO
+ set_target_properties(tlsh_shared PROPERTIES OUTPUT_NAME tlsh${BUILD_POSTFIX})
+ set_target_properties(tlsh_shared PROPERTIES VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}"
+ SOVERSION "0")
++
++include(GNUInstallDirs)
++install(TARGETS tlsh_shared DESTINATION ${CMAKE_INSTALL_LIBDIR})
++install(FILES ../include/tlsh.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
diff --git a/libraries/tlsh/slack-desc b/libraries/tlsh/slack-desc
new file mode 100644
index 0000000000..454ea2d901
--- /dev/null
+++ b/libraries/tlsh/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tlsh: tlsh (fuzzy matching library)
+tlsh:
+tlsh: TLSH is a fuzzy matching library. Given a byte stream with a minimum
+tlsh: length of 256 bytes, TLSH generates a hash value which can be used for
+tlsh: similarity comparisons.
+tlsh:
+tlsh: https://github.com/trendmicro/tlsh
+tlsh:
+tlsh:
+tlsh:
+tlsh:
diff --git a/libraries/tlsh/tlsh.SlackBuild b/libraries/tlsh/tlsh.SlackBuild
new file mode 100644
index 0000000000..50088ba967
--- /dev/null
+++ b/libraries/tlsh/tlsh.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/sh
+
+# Slackware build script for tlsh
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tlsh
+VERSION=${VERSION:-3.4.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# From Arch Linux (thanks!), but tweaked to omit static lib
+patch -p1 < $CWD/install-libraries.patch
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+mkdir -p $PKG/usr/bin
+install -D -m755 bin/tlsh_unittest $PKG/usr/bin
+ln -s tlsh_unittest $PKG/usr/bin/tlsh
+
+cd py_ext
+ python setup.py install --root=$PKG
+ if [ "${PYTHON3:-no}" == "yes" ]; then
+ rm -rf build
+ python3 setup.py install --root=$PKG
+ fi
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.pdf LICENSE NOTICE.txt PUBLIC.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/tlsh/tlsh.info b/libraries/tlsh/tlsh.info
new file mode 100644
index 0000000000..fbc5fd9578
--- /dev/null
+++ b/libraries/tlsh/tlsh.info
@@ -0,0 +1,10 @@
+PRGNAM="tlsh"
+VERSION="3.4.5"
+HOMEPAGE="https://github.com/trendmicro/tlsh"
+DOWNLOAD="https://github.com/trendmicro/tlsh/archive/v3.4.5/tlsh-3.4.5.tar.gz"
+MD5SUM="9e23c525cf5a1b0b44d9c161b2a637f8"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"