summaryrefslogtreecommitdiffstats
path: root/libraries/tamu_anova
diff options
context:
space:
mode:
author Petar Petrov2011-10-09 10:51:11 +0200
committer Robby Workman2011-10-12 04:20:30 +0200
commit414c1df02f42ae6faf281f62cc7982427f8d14d7 (patch)
tree1b5e43d8a77b1c2c0ffd2d1556164e3a9602dfb3 /libraries/tamu_anova
parent2b7c9cd06c6963ffae8087b1cce75a96b963073a (diff)
downloadslackbuilds-414c1df02f42ae6faf281f62cc7982427f8d14d7.tar.gz
libraries/tamu_anova: Added (Contains both single and two factor ANOVA)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries/tamu_anova')
-rw-r--r--libraries/tamu_anova/README15
-rw-r--r--libraries/tamu_anova/slack-desc19
-rw-r--r--libraries/tamu_anova/tamu_anova.SlackBuild91
-rw-r--r--libraries/tamu_anova/tamu_anova.info10
4 files changed, 135 insertions, 0 deletions
diff --git a/libraries/tamu_anova/README b/libraries/tamu_anova/README
new file mode 100644
index 0000000000..635baf7202
--- /dev/null
+++ b/libraries/tamu_anova/README
@@ -0,0 +1,15 @@
+ANOVA, or Analysis of Variance, is a method for comparing levels of
+some continuous response variable between different groups. The main
+idea is to compare variation within each group to variation between
+the groups; if the groups vary considerably from one group to another
+in comparison to the within group variation, we can reject the null
+hypothesis that all the groups have similar levels of the response
+variable.
+
+TAMU ANOVA contains both single and two factor ANOVA. Use of the
+package can be facilitated through linking to the compiled library
+tamuanova. The package function definitions are accessible through
+tamu_anova.h. The program must still be linked to the GSL (see GSL
+documentation on linking and compiling.)
+
+This requires gsl.
diff --git a/libraries/tamu_anova/slack-desc b/libraries/tamu_anova/slack-desc
new file mode 100644
index 0000000000..900fea8dea
--- /dev/null
+++ b/libraries/tamu_anova/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+tamu_anova: tamu_anova (Contains both single and two factor ANOVA)
+tamu_anova:
+tamu_anova: ANOVA, or Analysis of Variance, is a method for comparing levels of
+tamu_anova: some continuous response variable between different groups.
+tamu_anova: TAMU ANOVA contains both single and two factor ANOVA.
+tamu_anova:
+tamu_anova:
+tamu_anova:
+tamu_anova:
+tamu_anova:
+tamu_anova: Home: http://www.stat.tamu.edu/~aredd/tamuanova/
diff --git a/libraries/tamu_anova/tamu_anova.SlackBuild b/libraries/tamu_anova/tamu_anova.SlackBuild
new file mode 100644
index 0000000000..b7ef034e78
--- /dev/null
+++ b/libraries/tamu_anova/tamu_anova.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/sh
+
+# Slackware build script for tamu_anova
+# Written by Petar Petrov, <ppetrov@paju.oulu.fi> and
+# hereby submitted to the public domain
+
+# THIS SLACKBUILD IS DISTRIBUTETD IN THE HOPE OF BEING
+# USEFUL BUT WITHOUT ANY WARRANTY. THE AUTHOR IS _NOT_
+# RESPONSIBLE FOR ANY DAMAGE OR DATA LOSS CAUSED BY IT.
+
+PRGNAM=tamu_anova
+VERSION=${VERSION:-0.2} # Website claims the version is 0.2.1. Weird.
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --build=$ARCH-slackware-linux
+
+# Make sure libdir is correct
+sed "s:/usr/lib:/usr/lib${LIBDIRSUFFIX}:" -i Makefile.am
+sed "s:/usr/lib:/usr/lib${LIBDIRSUFFIX}:" -i Makefile.in
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -f $PKG/usr/info/dir
+gzip -9 $PKG/usr/info/*.info*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING INSTALL README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/tamu_anova/tamu_anova.info b/libraries/tamu_anova/tamu_anova.info
new file mode 100644
index 0000000000..c8b192c026
--- /dev/null
+++ b/libraries/tamu_anova/tamu_anova.info
@@ -0,0 +1,10 @@
+PRGNAM="tamu_anova"
+VERSION="0.2"
+HOMEPAGE="http://www.stat.tamu.edu/~aredd/tamuanova/"
+DOWNLOAD="http://www.stat.tamu.edu/~aredd/tamuanova/tamu_anova-0.2.tar.gz"
+MD5SUM="a98f9703d66a9da8c6458b7a643ada30"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Petar Petrov"
+EMAIL="ppetrov@paju.oulu.fi"
+APPROVED="Erik Hanson"