summaryrefslogtreecommitdiffstats
path: root/libraries/rrdtool
diff options
context:
space:
mode:
author Michael Johnson2010-05-11 14:56:25 +0200
committer Robby Workman2010-05-11 14:56:25 +0200
commit433dc8478e8950eaf38556e81224b5c03daf1303 (patch)
tree309084ffca22e89c190b669902ee95177f36dcad /libraries/rrdtool
parentff85971308477e1c3b7fb0476c4a9a4738d7b4c4 (diff)
downloadslackbuilds-433dc8478e8950eaf38556e81224b5c03daf1303.tar.gz
libraries/rrdtool: Initial import
Diffstat (limited to 'libraries/rrdtool')
-rw-r--r--libraries/rrdtool/README3
-rw-r--r--libraries/rrdtool/rrdtool.SlackBuild93
-rw-r--r--libraries/rrdtool/rrdtool.info8
-rw-r--r--libraries/rrdtool/slack-desc15
4 files changed, 119 insertions, 0 deletions
diff --git a/libraries/rrdtool/README b/libraries/rrdtool/README
new file mode 100644
index 0000000000..d06f163533
--- /dev/null
+++ b/libraries/rrdtool/README
@@ -0,0 +1,3 @@
+RRDTool is the industry standard data logging and graphing application.
+
+This package makes all bindings that are supported on the system.
diff --git a/libraries/rrdtool/rrdtool.SlackBuild b/libraries/rrdtool/rrdtool.SlackBuild
new file mode 100644
index 0000000000..012a10e201
--- /dev/null
+++ b/libraries/rrdtool/rrdtool.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for RRDTool
+
+# Written by <youngmug@animeneko.net>
+# Modified by the SlackBuilds.org team.
+
+# Exit on most errors
+set -e
+
+PRGNAM=rrdtool
+VERSION=1.2.19
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=`pwd`
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $TMP/$PRGNAM-$VERSION
+chown -R root:root .
+chmod -R a-s,u+w,go+r-w .
+
+# The python library is not added by default in the linking stage
+sed -i -r 's/^(LIBS = .*)/\0 -lpython2.4/' bindings/python/Makefile.in
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+RRDDOCDIR=/usr/doc/$PRGNAM-$VERSION \
+./configure \
+ --prefix=/usr \
+ --enable-perl-site-install
+
+make
+
+# Correct man paths in the Perl bindings.
+sed -r -i 's|/usr/share/man|/usr/man|g' bindings/perl-piped/Makefile
+sed -r -i 's|/usr/share/man|/usr/man|g' bindings/perl-shared/Makefile
+
+make install DESTDIR=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in `find . -type l` ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+# Remove perllocal.pod and other special files that don't need to be installed,
+# as they will overwrite what's already on the system.
+( cd $PKG
+ # Remove 'special' files
+ find . -name perllocal.pod \
+ -o -name ".packlist" \
+ -o -name "*.bs" \
+ | xargs rm -f
+)
+
+# And remove the directory leftovers
+rm -rf $PKG/usr/lib/perl5/5.8.8
+rm -rf $PKG/usr/lib/perl5/site_perl/5.8.8/i486-linux/auto/RRDp
+
+# Set correct permissions (mostly on the Perl bindings)
+( cd $PKG
+ find . -perm 444 -exec chmod 0644 {} \;
+ find . -perm 555 -exec chmod 0755 {} \;
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES CONTRIBUTORS COPYING COPYRIGHT NEWS README THREADS TODO \
+ WIN32-BUILD-TIPS.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/rrdtool/rrdtool.info b/libraries/rrdtool/rrdtool.info
new file mode 100644
index 0000000000..76c0d4e02a
--- /dev/null
+++ b/libraries/rrdtool/rrdtool.info
@@ -0,0 +1,8 @@
+PRGNAM="rrdtool"
+VERSION="1.2.19"
+HOMEPAGE="http://www.rrdtool.org/"
+DOWNLOAD="http://oss.oetiker.ch/rrdtool/pub/rrdtool-1.2.19.tar.gz"
+MD5SUM="df625d12e0585042a398ff946e32e3e7"
+MAINTAINER="Michael Johnson"
+EMAIL="youngmug@animeneko.net"
+APPROVED="danieldk"
diff --git a/libraries/rrdtool/slack-desc b/libraries/rrdtool/slack-desc
new file mode 100644
index 0000000000..8eb660e269
--- /dev/null
+++ b/libraries/rrdtool/slack-desc
@@ -0,0 +1,15 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+|-----handy-ruler------------------------------------------------------|
+rrdtool: rrdtool (RRDTool Logging and Graphing)
+rrdtool:
+rrdtool: RRD is the acronym for Round Robin Database. It is a system to
+rrdtool: store and display time-series data (i.e. network bandwidth,
+rrdtool: machine-room temperature, server load average).
+rrdtool:
+rrdtool: