summaryrefslogtreecommitdiffstats
path: root/libraries/rrdtool/rrdtool.SlackBuild
diff options
context:
space:
mode:
author Niels Horn2010-05-13 00:33:31 +0200
committer Erik Hanson2010-05-13 00:33:31 +0200
commit2d856c0be7c316bba4d7da21fb15a4d5ffeb14ba (patch)
tree8f70577497d683cb2555ecbe0523d15e2db86381 /libraries/rrdtool/rrdtool.SlackBuild
parent94bae28e455d0b010882a9f4fdc968dc592b0402 (diff)
downloadslackbuilds-2d856c0be7c316bba4d7da21fb15a4d5ffeb14ba.tar.gz
libraries/rrdtool: Updated for version 1.4.2
Diffstat (limited to 'libraries/rrdtool/rrdtool.SlackBuild')
-rw-r--r--libraries/rrdtool/rrdtool.SlackBuild30
1 files changed, 19 insertions, 11 deletions
diff --git a/libraries/rrdtool/rrdtool.SlackBuild b/libraries/rrdtool/rrdtool.SlackBuild
index ac41a784d6..317131322f 100644
--- a/libraries/rrdtool/rrdtool.SlackBuild
+++ b/libraries/rrdtool/rrdtool.SlackBuild
@@ -2,14 +2,16 @@
# Slackware build script for RRDTool
-# Written by <youngmug@animeneko.net>
+# Originally written by <youngmug@animeneko.net>
# Modified by the SlackBuilds.org team.
+# Versions >= 1.4.2 maintained by Niels Horn <niels.horn@gmail.com>
+# revision date: 2009/12/08
# Exit on most errors
set -e
PRGNAM=rrdtool
-VERSION=1.2.19
+VERSION=1.4.2
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -23,8 +25,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
rm -rf $PKG
@@ -36,18 +43,17 @@ cd $TMP/$PRGNAM-$VERSION
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
-# The python library is not added by default in the linking stage
-sed -i -r "s/^(LIBS = .*)/\0 -lpython${PYTHON}/" bindings/python/Makefile.in
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
RRDDOCDIR=/usr/doc/$PRGNAM-$VERSION \
./configure \
--prefix=/usr \
+ --mandir=/usr/man \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
--disable-static \
--with-perl-options='INSTALLDIRS=vendor'
-make
+make
# Correct man paths in the Perl bindings.
sed -r -i 's|/usr/share/man|/usr/man|g' bindings/perl-piped/Makefile
@@ -56,8 +62,10 @@ sed -r -i 's|/usr/share/man|/usr/man|g' bindings/perl-shared/Makefile
make install DESTDIR=$PKG
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
( cd $PKG/usr/man
@@ -76,8 +84,8 @@ make install DESTDIR=$PKG
)
# And remove the directory leftovers
-rm -rf $PKG/usr/lib/perl5/${PERL}
-rm -rf $PKG/usr/lib/perl5/site_perl/${PERL}/i486-linux/auto/RRDp
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/perl5/${PERL}
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/perl5/site_perl/${PERL}/$ARCH-linux/auto/RRDp
# Set correct permissions (mostly on the Perl bindings)
( cd $PKG
@@ -94,4 +102,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}