summaryrefslogtreecommitdiffstats
path: root/libraries/reportlab
diff options
context:
space:
mode:
author LukenShiro2010-05-11 22:24:21 +0200
committer Robby Workman2010-05-11 22:24:21 +0200
commit135a1f540f4999ed0da91d4538decf9c0ea4fd66 (patch)
tree2024d64f8fd19cbdc057d6d8bb2d7fb2ce9b7866 /libraries/reportlab
parent711134a8fe1aa66a51c3097391d588cdb653f076 (diff)
downloadslackbuilds-135a1f540f4999ed0da91d4538decf9c0ea4fd66.tar.gz
libraries/reportlab: Updated for version 2.2
Diffstat (limited to 'libraries/reportlab')
-rw-r--r--libraries/reportlab/README13
-rw-r--r--libraries/reportlab/reportlab.SlackBuild44
-rw-r--r--libraries/reportlab/reportlab.info6
-rw-r--r--libraries/reportlab/slack-desc4
4 files changed, 42 insertions, 25 deletions
diff --git a/libraries/reportlab/README b/libraries/reportlab/README
index bc2ea13a14..6cb7da41dd 100644
--- a/libraries/reportlab/README
+++ b/libraries/reportlab/README
@@ -4,24 +4,23 @@ developers or creative design professionals who need to quickly and
easily create or automate complex (even data-driven) documents.
It is released by ReportLab Inc., under BSD license.
+It includes binary extensions (previously available separately)
+_rl_accel and renderPM
+
It has the following features:
- create professional portable documents
- real document layout engine (Platypus)
-- flowable objects such as paragraphs, headlines, tables, images,
-graphics, etc.
+- flowable objects (paragraphs, headlines, tables, images, graphics, etc.)
- arbitrary Type-1 fonts
- bitmap images, vector graphics
- library of reusable primitive shapes
- extensible widget library
-- uses Python, a clean OO language
- layered architecture
- includes simple demos and more complex tools
- allows for any data sources
-- fully available source code
- strong community support
- platform-independent
- includes PythonPoint - PDF Presentation Tool
-If pil (Python Imaging library) is installed (it is available from
-Slackbuilds.org too), reportlab can use it for working with bitmap
-images.
+If pil (Python Imaging library) is installed (it is also available from
+Slackbuilds.org), reportlab can use it for working with bitmap images.
diff --git a/libraries/reportlab/reportlab.SlackBuild b/libraries/reportlab/reportlab.SlackBuild
index 38ca63315d..ea36add148 100644
--- a/libraries/reportlab/reportlab.SlackBuild
+++ b/libraries/reportlab/reportlab.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for reportlab
-# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-8 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,43 +22,61 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Exit on most errors
-set -e
PRGNAM=reportlab
-SRC_PRGNAM=ReportLab
-VERSION=2.1
-SRC_VERSION=2_1
-ARCH=${ARCH:-noarch}
+VERSION=2.2
+ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="changes license.txt README docs/*.pdf"
+SRC_PRGNAM=ReportLab
+SRC_VERSION=$(echo $VERSION | tr . _)
+
+# directory for python packages
+PYTHONDIR=$(python -c 'import sys, os; print os.path.join("/usr/lib", "python%s" % sys.version[:3], "site-packages")')
+DOCFILES="CHANGES.txt LICENSE.txt README.txt docs/*.pdf"
+OTHERPYFILES="demos tools" # tests removed
+
+set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf ${PRGNAM}_${SRC_VERSION}
tar xvzf $CWD/${SRC_PRGNAM}_${SRC_VERSION}.tgz || exit 1
-cd ${PRGNAM}_${SRC_VERSION}/${PRGNAM}
+cd ${SRC_PRGNAM}_${SRC_VERSION}/
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# copy documentation .pdf files and move text files to avoid file duplication in python directory
+# Generate pdf documentation
+( cd docs
+ # workaround due to dependency loop if reportlab isn't previously installed
+ PYTHONPATH=$PYTHONPATH:$TMP/${SRC_PRGNAM}_${SRC_VERSION}/src/ python genAll.py
+)
+
+# Move documentation .pdf files and text files to avoid file duplication in
+# python directory
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
mv $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# Copy demos and tools directories into python package's home
+# BTW scripts in tests are partially broken (they need PYTHONPATH variable
+# to be set, and have some other flaws), so I don't include them anymore.
+mkdir -p $PKG/$PYTHONDIR/$PRGNAM/
+cp -R $OTHERPYFILES $PKG/$PYTHONDIR/$PRGNAM
+
+cd $TMP/${SRC_PRGNAM}_${SRC_VERSION}
python setup.py build || exit 1
python setup.py install --root=$PKG || exit 1
-( cd $PKG
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-)
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/libraries/reportlab/reportlab.info b/libraries/reportlab/reportlab.info
index 73956b21a9..7c73aa625e 100644
--- a/libraries/reportlab/reportlab.info
+++ b/libraries/reportlab/reportlab.info
@@ -1,8 +1,8 @@
PRGNAM="reportlab"
-VERSION="2.1"
+VERSION="2.2"
HOMEPAGE="http://www.reportlab.org/"
-DOWNLOAD="http://www.reportlab.org/ftp/ReportLab_2_1.tgz"
-MD5SUM="d6eefe9e6e06aaa1315462045c9726ba"
+DOWNLOAD="http://www.reportlab.org/ftp/ReportLab_2_2.tgz"
+MD5SUM="46d0e2dd6c112e7c989fe93b993801fb"
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
APPROVED="rworkman"
diff --git a/libraries/reportlab/slack-desc b/libraries/reportlab/slack-desc
index 766401975e..14b8405bc0 100644
--- a/libraries/reportlab/slack-desc
+++ b/libraries/reportlab/slack-desc
@@ -13,7 +13,7 @@ reportlab: PDF generating solution, suitable for web publishers, developers
reportlab: or creative design professionals who need to quickly and easily
reportlab: create or automate complex (even data-driven) documents.
reportlab: It is released by ReportLab Inc., under BSD license.
-reportlab: This version does not include optional accelerator C extension
-reportlab: _rl_accel Homepage: http://www.reportlab.org
+reportlab:
+reportlab: Homepage: http://www.reportlab.org
reportlab:
reportlab: