summaryrefslogtreecommitdiffstats
path: root/libraries/python3-pillow
diff options
context:
space:
mode:
author Philip Lacroix2017-02-17 12:54:58 +0100
committer David Spencer2017-02-17 22:52:09 +0100
commit7c4305a91d5201ad5261dd698ca41d410ca324ff (patch)
treefdf2f796cfeb3a133208155a1bca1808ce2b3edb /libraries/python3-pillow
parent3fbedf1fee4b6b4ce1bd57f3de188cdaf70849ba (diff)
downloadslackbuilds-7c4305a91d5201ad5261dd698ca41d410ca324ff.tar.gz
libraries/python3-pillow: Switch to i586.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/python3-pillow')
-rw-r--r--libraries/python3-pillow/README15
-rw-r--r--libraries/python3-pillow/python3-pillow.SlackBuild21
-rw-r--r--libraries/python3-pillow/slack-desc6
3 files changed, 17 insertions, 25 deletions
diff --git a/libraries/python3-pillow/README b/libraries/python3-pillow/README
index 94f59fd66a..8bd903c6d8 100644
--- a/libraries/python3-pillow/README
+++ b/libraries/python3-pillow/README
@@ -1,13 +1,8 @@
The Python Imaging Library (PIL) adds image processing capabilities to
-your Python environment. This library provides extensive file format
-support, an efficient internal representation, and powerful image
+your Python environment. This library provides extensive file format
+support, an efficient internal representation and powerful image
processing capabilities.
-This SlackBuild provides the PIL libraries with support for Python3.
-It is intended to be a complement to python-pillow, not to replace it.
-
-***Warning***
-
-Pillow and PIL CANNOT co-exist in the same environment. Before
-installing Pillow, please uninstall PIL.
-https://pillow.readthedocs.org/en/latest/installation.html
+NOTE - This SlackBuild provides PIL libraries with support for Python3. It
+is intended to be a complement to Slackware's default python-pillow, not to
+replace it, hence it doesn't include the scripts that would go to /usr/bin.
diff --git a/libraries/python3-pillow/python3-pillow.SlackBuild b/libraries/python3-pillow/python3-pillow.SlackBuild
index f714695546..fca5f71d14 100644
--- a/libraries/python3-pillow/python3-pillow.SlackBuild
+++ b/libraries/python3-pillow/python3-pillow.SlackBuild
@@ -2,9 +2,9 @@
# Slackware build script for python3-pillow
-# Copyright 2015 by Philip Lacroix <slackph at posteo dot de>
+# Copyright 2015-2017 Philip Lacroix <slackph at posteo dot de>
#
-# Based on the build script for python-pillow by the following authors:
+# Based on build script for python-pillow by following authors:
# Copyright 2009, 2010, 2013, 2014 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2014 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2015 Brenton Earl <brent at exitstatusone dot com>
@@ -26,20 +26,16 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# This SlackBuild provides PIL libraries with support for Python3. It is a
-# complement to python-pillow, not a replacement, and as such it doesn't
-# include the scripts in $PKG/usr/bin.
PRGNAM=python3-pillow
SRCNAM=Pillow
VERSION=${VERSION:-3.0.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -50,8 +46,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -89,8 +85,9 @@ python3 setup.py install --root=$PKG
# Safety check to prevent changes in the install process of a
# different version of Pillow that might allow files in /usr/bin.
if [ -e $PKG/usr/bin ]; then
- echo 'Warning - This package should not put files in /usr/bin: exiting'
- exit
+ echo -e "\n* Warning - This package is not allowed to put files in /usr/bin,"
+ echo "* as they conflict with Slackware's default python-pillow. Exiting."
+ exit 1
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
diff --git a/libraries/python3-pillow/slack-desc b/libraries/python3-pillow/slack-desc
index e97ef968a7..446cde956c 100644
--- a/libraries/python3-pillow/slack-desc
+++ b/libraries/python3-pillow/slack-desc
@@ -9,11 +9,11 @@
python3-pillow: python3-pillow (Python3 support for python-pillow)
python3-pillow:
python3-pillow: The Python Imaging Library (PIL) adds image processing capabilities
-python3-pillow: to your Python environment. This library provides extensive file
-python3-pillow: format support, an efficient internal representation, and powerful
+python3-pillow: to your Python environment. This library provides extensive file
+python3-pillow: format support, an efficient internal representation and powerful
python3-pillow: image processing capabilities.
python3-pillow:
python3-pillow: This package provides the PIL libraries with support for Python3. It
python3-pillow: is intended to be a complement to python-pillow, not to replace it.
python3-pillow:
-python3-pillow: PIL homepage: https://python3-pillow.github.io/
+python3-pillow: Homepage: https://python3-pillow.github.io/