summaryrefslogtreecommitdiffstats
path: root/libraries/python-musicbrainz2
diff options
context:
space:
mode:
author Larry Hajali2010-05-12 23:31:18 +0200
committer David Somero2010-05-12 23:31:18 +0200
commit89d2de7999fa5460a46d6d05bf14edb8e41475b8 (patch)
treebad5a118b698da72404bc1839c30803298341f33 /libraries/python-musicbrainz2
parentbab6f3a953a63044b73839fedfea966e1c799173 (diff)
downloadslackbuilds-89d2de7999fa5460a46d6d05bf14edb8e41475b8.tar.gz
libraries/python-musicbrainz2: Added to 12.2 repository
Diffstat (limited to 'libraries/python-musicbrainz2')
-rw-r--r--libraries/python-musicbrainz2/README7
-rw-r--r--libraries/python-musicbrainz2/python-musicbrainz2.SlackBuild50
-rw-r--r--libraries/python-musicbrainz2/python-musicbrainz2.info8
-rw-r--r--libraries/python-musicbrainz2/slack-desc19
4 files changed, 84 insertions, 0 deletions
diff --git a/libraries/python-musicbrainz2/README b/libraries/python-musicbrainz2/README
new file mode 100644
index 0000000000..cb21b0a6db
--- /dev/null
+++ b/libraries/python-musicbrainz2/README
@@ -0,0 +1,7 @@
+Python bindings for the MusicBrainz XML Web Service.
+
+This python package contains various modules for accessing the MusicBrainz
+web service, as well as parsing the MusicBrainz Metadata XML (MMD), or
+calculating DiscIDs from Audio CDs.
+
+Requires libdiscid available at SlackBuilds.org. \ No newline at end of file
diff --git a/libraries/python-musicbrainz2/python-musicbrainz2.SlackBuild b/libraries/python-musicbrainz2/python-musicbrainz2.SlackBuild
new file mode 100644
index 0000000000..2db1511a74
--- /dev/null
+++ b/libraries/python-musicbrainz2/python-musicbrainz2.SlackBuild
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# Slackware build script for python-muzicbrainz2
+
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=python-musicbrainz2
+VERSION=${VERSION:-0.6.0}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/python-musicbrainz2/python-musicbrainz2.info b/libraries/python-musicbrainz2/python-musicbrainz2.info
new file mode 100644
index 0000000000..aef8fb65c0
--- /dev/null
+++ b/libraries/python-musicbrainz2/python-musicbrainz2.info
@@ -0,0 +1,8 @@
+PRGNAM="python-musicbrainz2"
+VERSION="0.6.0"
+HOMEPAGE="http://musicbrainz.org/doc/PythonMusicBrainz2"
+DOWNLOAD="http://ftp.musicbrainz.org/pub/musicbrainz/python-musicbrainz2/python-musicbrainz2-0.6.0.tar.gz"
+MD5SUM="2ab23c3c15885d29ebd01bcc44ccc823"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero"
diff --git a/libraries/python-musicbrainz2/slack-desc b/libraries/python-musicbrainz2/slack-desc
new file mode 100644
index 0000000000..8ea4c615a2
--- /dev/null
+++ b/libraries/python-musicbrainz2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-musicbrainz2: Python-Musicbrainz2
+python-musicbrainz2:
+python-musicbrainz2: Python Bindings for the MusicBrainz XML Web Service.
+python-musicbrainz2:
+python-musicbrainz2: Homepage: http://musicbrainz.org/doc/PythonMusicBrainz2
+python-musicbrainz2:
+python-musicbrainz2:
+python-musicbrainz2:
+python-musicbrainz2:
+python-musicbrainz2:
+python-musicbrainz2: