summaryrefslogtreecommitdiffstats
path: root/libraries/python-meld3
diff options
context:
space:
mode:
author digwtx2018-04-15 12:26:58 +0200
committer Willy Sudiarto Raharjo2018-04-21 02:42:57 +0200
commit16cd834af429c85207b79ccc6c3c6766505e9877 (patch)
treed5341cbdd42850a19b5696d6573a32ba297190a7 /libraries/python-meld3
parentf3a961c98e3229ea3154e57ad2e844889d3df10f (diff)
downloadslackbuilds-16cd834af429c85207b79ccc6c3c6766505e9877.tar.gz
libraries/python-meld3: Added (HTML/XML templating engine).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/python-meld3')
-rw-r--r--libraries/python-meld3/README11
-rw-r--r--libraries/python-meld3/python-meld3.SlackBuild69
-rw-r--r--libraries/python-meld3/python-meld3.info10
-rw-r--r--libraries/python-meld3/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/libraries/python-meld3/README b/libraries/python-meld3/README
new file mode 100644
index 0000000000..539111ee00
--- /dev/null
+++ b/libraries/python-meld3/README
@@ -0,0 +1,11 @@
+meld3 is an HTML/XML templating system for Python which keeps template markup
+and dynamic rendering logic separate from one another. See
+http://www.entrian.com/PyMeld for a treatise on the benefits of this pattern.
+
+meld3 can deal with HTML or XML/XHTML input and can output well-formed HTML
+or XML/XHTML.
+
+meld3 is a variation of Paul Winkler’s Meld2, which is itself a variation
+of Richie Hindle’s PyMeld.
+
+meld3 uses Frederik Lundh’s ElementTree library.
diff --git a/libraries/python-meld3/python-meld3.SlackBuild b/libraries/python-meld3/python-meld3.SlackBuild
new file mode 100644
index 0000000000..8c1af6e8eb
--- /dev/null
+++ b/libraries/python-meld3/python-meld3.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+
+# Slackware build script for python-meld3
+# Copyright 2018 digwtx <wtx358@qq.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-meld3
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=meld3
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-meld3/python-meld3.info b/libraries/python-meld3/python-meld3.info
new file mode 100644
index 0000000000..695c98dfb2
--- /dev/null
+++ b/libraries/python-meld3/python-meld3.info
@@ -0,0 +1,10 @@
+PRGNAM="python-meld3"
+VERSION="1.0.2"
+HOMEPAGE="https://github.com/Supervisor/meld3"
+DOWNLOAD="https://pypi.python.org/packages/45/a0/317c6422b26c12fe0161e936fc35f36552069ba8e6f7ecbd99bbffe32a5f/meld3-1.0.2.tar.gz"
+MD5SUM="3ccc78cd79cffd63a751ad7684c02c91"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="digwtx"
+EMAIL="wtx358@qq.com"
diff --git a/libraries/python-meld3/slack-desc b/libraries/python-meld3/slack-desc
new file mode 100644
index 0000000000..cd9cc55cd5
--- /dev/null
+++ b/libraries/python-meld3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-meld3: python-meld3 (HTML/XML templating engine)
+python-meld3:
+python-meld3: meld3 is an HTML/XML templating system for Python
+python-meld3: which keeps template markup and dynamic rendering logic separate
+python-meld3: from one another.
+python-meld3:
+python-meld3: Homepage: https://github.com/Supervisor/meld3
+python-meld3:
+python-meld3:
+python-meld3:
+python-meld3: