summaryrefslogtreecommitdiffstats
path: root/libraries/python-librtmp
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-17 14:16:14 +0100
committer Erik Hanson2014-01-30 06:21:05 +0100
commitbdb0b2a1690da25bd9bfacb5020a01f108afded1 (patch)
treee86de10554b9a13408889892bac124448763780b /libraries/python-librtmp
parentabae8ed73c14aa6374edb9c2626136c8c2503c51 (diff)
downloadslackbuilds-bdb0b2a1690da25bd9bfacb5020a01f108afded1.tar.gz
libraries/python-librtmp: Added (Python bindings for librtmp).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/python-librtmp')
-rw-r--r--libraries/python-librtmp/README2
-rw-r--r--libraries/python-librtmp/python-librtmp.SlackBuild86
-rw-r--r--libraries/python-librtmp/python-librtmp.info10
-rw-r--r--libraries/python-librtmp/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/libraries/python-librtmp/README b/libraries/python-librtmp/README
new file mode 100644
index 0000000000..27f05721e2
--- /dev/null
+++ b/libraries/python-librtmp/README
@@ -0,0 +1,2 @@
+python-librtmp is a Python interface to librtmp. It uses cffi to
+interface with the C library librtmp.
diff --git a/libraries/python-librtmp/python-librtmp.SlackBuild b/libraries/python-librtmp/python-librtmp.SlackBuild
new file mode 100644
index 0000000000..6801b7d0b3
--- /dev/null
+++ b/libraries/python-librtmp/python-librtmp.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for python-librtmp
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-librtmp
+VERSION=${VERSION:-0.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst LICENSE AUTHORS.rst CONTRIBUTING.rst HISTORY.rst PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python-librtmp/python-librtmp.info b/libraries/python-librtmp/python-librtmp.info
new file mode 100644
index 0000000000..990e1b0e63
--- /dev/null
+++ b/libraries/python-librtmp/python-librtmp.info
@@ -0,0 +1,10 @@
+PRGNAM="python-librtmp"
+VERSION="0.1.2"
+HOMEPAGE="https://github.com/chrippa/python-librtmp"
+DOWNLOAD="https://pypi.python.org/packages/source/p/python-librtmp/python-librtmp-0.1.2.tar.gz"
+MD5SUM="2a1d37dc84f09a5c5a99bc435029c733"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools rtmpdump cffi"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/python-librtmp/slack-desc b/libraries/python-librtmp/slack-desc
new file mode 100644
index 0000000000..f253b98d0a
--- /dev/null
+++ b/libraries/python-librtmp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-librtmp: python-librtmp (Python bindings for librtmp)
+python-librtmp:
+python-librtmp: python-librtmp is a Python interface to librtmp.
+python-librtmp: It uses cffi to interface with the C library librtmp.
+python-librtmp:
+python-librtmp:
+python-librtmp:
+python-librtmp:
+python-librtmp:
+python-librtmp: Homepage: https://github.com/chrippa/python-librtmp
+python-librtmp: