summaryrefslogtreecommitdiffstats
path: root/libraries/pytables
diff options
context:
space:
mode:
author LukenShiro2010-05-11 20:01:00 +0200
committer Robby Workman2010-05-11 20:01:00 +0200
commitd7699987502dabd2da62acc912df511a9d1cf80c (patch)
treebead2860105ba0871fb820c4e0353691cca4118d /libraries/pytables
parent56b916f1bc0ab75c0d919d5e888c5bb3f29e0e69 (diff)
downloadslackbuilds-d7699987502dabd2da62acc912df511a9d1cf80c.tar.gz
libraries/pytables: Added to 12.0 repository
Diffstat (limited to 'libraries/pytables')
-rw-r--r--libraries/pytables/README19
-rw-r--r--libraries/pytables/pytables.SlackBuild77
-rw-r--r--libraries/pytables/pytables.info8
-rw-r--r--libraries/pytables/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/libraries/pytables/README b/libraries/pytables/README
new file mode 100644
index 0000000000..c0d4b4e3fc
--- /dev/null
+++ b/libraries/pytables/README
@@ -0,0 +1,19 @@
+PyTables is a package for managing hierarchical datasets
+and designed to efficiently and easily cope with extremely
+large amounts of data. It optimizes memory and disk resources
+so that data takes much less space than other solutions such
+as relational or object oriented databases.
+
+PyTables has been designed to fulfill the next requirements:
+ 1. Allow to structure your data in a hierarchical way.
+ 2. Easy to use. It implements the NaturalNaming scheme for
+ allowing convenient access to the data.
+ 3. All the cells in datasets can be multidimensional entities.
+ 4. Most of the I/O operations speed should be only limited by
+ the underlying I/O subsystem.
+ 5. Enable the end user to save large datasets in a efficient
+ way, i.e. each single byte of data on disk has to be represented
+ by one byte plus a small fraction when loaded in memory.
+
+It depends on "numpy" and "hdf5" packages, both of which are
+available from SlackBuilds.org
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
new file mode 100644
index 0000000000..b7eff3d475
--- /dev/null
+++ b/libraries/pytables/pytables.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for pytables
+
+# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Exit on most errors
+set -e
+
+PRGNAM=pytables
+VERSION=2.0.1
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="RELEASE_NOTES.txt LICENSES/ MIGRATING_TO_2.x.txt THANKS ANNOUNCE.txt \
+ LICENSE.txt PKG-INFO TODO.txt README.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+fi
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+python setup.py build
+python setup.py install --prefix=/usr/ --root=$PKG
+
+# Copy documentation, examples, contrib, and bench files
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a doc/{html,scripts,text,usersguide.pdf} $PKG/usr/doc/$PRGNAM-$VERSION/
+mkdir -p $PKG/usr/share/$PRGNAM/
+cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
+
+( cd $PKG
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pytables/pytables.info b/libraries/pytables/pytables.info
new file mode 100644
index 0000000000..2d800f827f
--- /dev/null
+++ b/libraries/pytables/pytables.info
@@ -0,0 +1,8 @@
+PRGNAM="pytables"
+VERSION="2.0.1"
+HOMEPAGE="http://www.pytables.org/moin"
+DOWNLOAD="http://www.pytables.org/download/stable/pytables-2.0.1.tar.gz"
+MD5SUM="384d98b30cc7658a0b6cd640e04022dd"
+MAINTAINER="LukenShiro"
+EMAIL="lukenshiro@ngi.it"
+APPROVED="rworkman"
diff --git a/libraries/pytables/slack-desc b/libraries/pytables/slack-desc
new file mode 100644
index 0000000000..28c3ab8d64
--- /dev/null
+++ b/libraries/pytables/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+pytables: pytables (Hierarchical datasets in Python)
+pytables:
+pytables: PyTables is a package for managing hierarchical datasets
+pytables: and designed to efficiently and easily cope with extremely
+pytables: large amounts of data. It optimizes memory and disk resources
+pytables: so that data takes much less space than other solutions such
+pytables: as relational or object oriented databases.
+pytables:
+pytables: http://www.pytables.org/moin
+pytables:
+pytables: