summaryrefslogtreecommitdiffstats
path: root/libraries/pytables
diff options
context:
space:
mode:
author LukenShiro2010-05-11 22:24:17 +0200
committer Robby Workman2010-05-11 22:24:17 +0200
commit46d0dad7c8ee34d47e18e68a7a31a61d3395f7c3 (patch)
tree36692f741e76aa8d82dbeec466bd486178ae7130 /libraries/pytables
parente4326b0bb4d2aad583e4fee0c1c2f9c436d81181 (diff)
downloadslackbuilds-46d0dad7c8ee34d47e18e68a7a31a61d3395f7c3.tar.gz
libraries/pytables: Updated for version 2.0.4
Diffstat (limited to 'libraries/pytables')
-rw-r--r--libraries/pytables/README9
-rw-r--r--libraries/pytables/pytables.SlackBuild19
-rw-r--r--libraries/pytables/pytables.info6
-rw-r--r--libraries/pytables/slack-desc4
4 files changed, 20 insertions, 18 deletions
diff --git a/libraries/pytables/README b/libraries/pytables/README
index c0d4b4e3fc..b5d3203f6e 100644
--- a/libraries/pytables/README
+++ b/libraries/pytables/README
@@ -12,8 +12,9 @@ PyTables has been designed to fulfill the next requirements:
4. Most of the I/O operations speed should be only limited by
the underlying I/O subsystem.
5. Enable the end user to save large datasets in a efficient
- way, i.e. each single byte of data on disk has to be represented
- by one byte plus a small fraction when loaded in memory.
+ way, i.e. each single byte of data on disk has to be
+ represented by one byte plus a small fraction when loaded
+ in memory.
-It depends on "numpy" and "hdf5" packages, both of which are
-available from SlackBuilds.org
+This requires numpy and hdf5, both of which are available from
+SlackBuilds.org.
diff --git a/libraries/pytables/pytables.SlackBuild b/libraries/pytables/pytables.SlackBuild
index b7eff3d475..120c380559 100644
--- a/libraries/pytables/pytables.SlackBuild
+++ b/libraries/pytables/pytables.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pytables
-# Copyright 2007 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2007-8 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,14 +22,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# Exit on most errors
-set -e
-
PRGNAM=pytables
-VERSION=2.0.1
+VERSION=${VERSION:-2.0.4}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -42,8 +40,12 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -53,25 +55,24 @@ cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-CFLAGS="$SLKCFLAGS" \
python setup.py build
-python setup.py install --prefix=/usr/ --root=$PKG
+python setup.py install --prefix=/usr --root=$PKG
# Copy documentation, examples, contrib, and bench files
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/{html,scripts,text,usersguide.pdf} $PKG/usr/doc/$PRGNAM-$VERSION/
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/usr/share/$PRGNAM/
cp -a examples contrib bench $PKG/usr/share/$PRGNAM/
( cd $PKG
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/pytables/pytables.info b/libraries/pytables/pytables.info
index 2d800f827f..032b4c685a 100644
--- a/libraries/pytables/pytables.info
+++ b/libraries/pytables/pytables.info
@@ -1,8 +1,8 @@
PRGNAM="pytables"
-VERSION="2.0.1"
+VERSION="2.0.4"
HOMEPAGE="http://www.pytables.org/moin"
-DOWNLOAD="http://www.pytables.org/download/stable/pytables-2.0.1.tar.gz"
-MD5SUM="384d98b30cc7658a0b6cd640e04022dd"
+DOWNLOAD="http://www.pytables.org/download/stable/pytables-2.0.4.tar.gz"
+MD5SUM="e9892962256d28c898ea0c985e60c09e"
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
APPROVED="rworkman"
diff --git a/libraries/pytables/slack-desc b/libraries/pytables/slack-desc
index 28c3ab8d64..cc2f1cd98c 100644
--- a/libraries/pytables/slack-desc
+++ b/libraries/pytables/slack-desc
@@ -5,7 +5,7 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler----------------------------------------------------|
pytables: pytables (Hierarchical datasets in Python)
pytables:
pytables: PyTables is a package for managing hierarchical datasets
@@ -14,6 +14,6 @@ pytables: large amounts of data. It optimizes memory and disk resources
pytables: so that data takes much less space than other solutions such
pytables: as relational or object oriented databases.
pytables:
-pytables: http://www.pytables.org/moin
+pytables: Homepage: http://www.pytables.org/moin
pytables:
pytables: