summaryrefslogtreecommitdiffstats
path: root/libraries/pies
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-23 17:15:02 +0100
committer Erik Hanson2014-01-30 06:21:11 +0100
commit83fd90cd928e75ac60ee0b57700212c438950272 (patch)
treef664572f96f0a21cc903dc17e7a796392f13f1ff /libraries/pies
parent87c7ddacd0d0d7183c9dfc8aa6f253814e3a6bcc (diff)
downloadslackbuilds-83fd90cd928e75ac60ee0b57700212c438950272.tar.gz
libraries/pies: Added (Simple way to write Py2 and Py3 program).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/pies')
-rw-r--r--libraries/pies/README3
-rw-r--r--libraries/pies/pies.SlackBuild88
-rw-r--r--libraries/pies/pies.info10
-rw-r--r--libraries/pies/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/libraries/pies/README b/libraries/pies/README
new file mode 100644
index 0000000000..cb7ad6fbc3
--- /dev/null
+++ b/libraries/pies/README
@@ -0,0 +1,3 @@
+Pies is a Python2 & 3 Compatibility layer with the philosophy that all
+code should be Python3 code. Starting from this viewpoint means that
+when running on Python3 pies adds virtually no overhead.
diff --git a/libraries/pies/pies.SlackBuild b/libraries/pies/pies.SlackBuild
new file mode 100644
index 0000000000..83fabfba1c
--- /dev/null
+++ b/libraries/pies/pies.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for pies
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=pies
+VERSION=${VERSION:-2.5.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp '-a' \
+ PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/pies/pies.info b/libraries/pies/pies.info
new file mode 100644
index 0000000000..48004cada7
--- /dev/null
+++ b/libraries/pies/pies.info
@@ -0,0 +1,10 @@
+PRGNAM="pies"
+VERSION="2.5.5"
+HOMEPAGE="https://github.com/timothycrosley/pies"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pies/pies-2.5.5.tar.gz"
+MD5SUM="71d4d85edbb289afc1b34f49f505b726"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pies2overrides enum34"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/pies/slack-desc b/libraries/pies/slack-desc
new file mode 100644
index 0000000000..1ccd73acf4
--- /dev/null
+++ b/libraries/pies/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pies: pies (Simple way to write Py2 and Py3 program)
+pies:
+pies: The simplest (and tastiest) way to write one program that runs on
+pies: Python 2.6+ and Python 3.
+pies:
+pies: Homepage: https://github.com/timothycrosley/pies
+pies:
+pies:
+pies:
+pies:
+pies: