summaryrefslogtreecommitdiffstats
path: root/libraries/physfs
diff options
context:
space:
mode:
author Erik Hanson2010-05-13 00:33:02 +0200
committer David Somero2010-05-13 00:33:02 +0200
commitbfbf81face473ac76dd65ad36f7955ef0319c4fc (patch)
tree725cea3ceb96928692fd61e3fb5a766f020c9427 /libraries/physfs
parent1c0b06ff290a5f8515f88af0322f928f2e713a5f (diff)
downloadslackbuilds-bfbf81face473ac76dd65ad36f7955ef0319c4fc.tar.gz
libraries/physfs: Updated for version 2.0.0
Diffstat (limited to 'libraries/physfs')
-rw-r--r--libraries/physfs/physfs.SlackBuild51
-rw-r--r--libraries/physfs/physfs.info10
2 files changed, 47 insertions, 14 deletions
diff --git a/libraries/physfs/physfs.SlackBuild b/libraries/physfs/physfs.SlackBuild
index c5e4a4ec8f..c6aaf8cb03 100644
--- a/libraries/physfs/physfs.SlackBuild
+++ b/libraries/physfs/physfs.SlackBuild
@@ -1,11 +1,29 @@
#!/bin/sh
-
+#
# Slackware build script for physfs
-# Written by Erik Hanson erik@slackbuilds.org
-# Modified for version 1.1.1 by Heinz Wiesinger <hmwiesinger@gmx.at>
+#
+# Copyright 2009 Erik W. Hanson, Minneapolis, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=physfs
-VERSION=1.1.1
+VERSION=2.0.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
@@ -17,8 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
rm -rf $PKG
@@ -30,17 +53,25 @@ cd $PRGNAM-$VERSION || exit 1
chown -R root:root .
chmod -R a-s,u+w,go+r-w .
+# LIB_SUFFIX is ignored work around it.
+sed -i -e "s|DESTINATION lib|DESTINATION lib${LIBDIRSUFFIX}|g" \
+ CMakeLists.txt
+
cmake \
- -DCMAKE_C_FLAGS="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr || exit 1
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX:STRING=${LIBDIRSUFFIX} || exit 1
make || exit 1
make install DESTDIR=$PKG || exit 1
( cd $PKG
- find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
@@ -52,4 +83,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/physfs/physfs.info b/libraries/physfs/physfs.info
index de576c28c1..011eca7497 100644
--- a/libraries/physfs/physfs.info
+++ b/libraries/physfs/physfs.info
@@ -1,8 +1,10 @@
PRGNAM="physfs"
-VERSION="1.1.1"
+VERSION="2.0.0"
HOMEPAGE="http://icculus.org/physfs/"
-DOWNLOAD="http://icculus.org/physfs/downloads/physfs-1.1.1.tar.gz"
-MD5SUM="0359b67793c1c14f00de1d1bbeb8ed6a"
+DOWNLOAD="http://icculus.org/physfs/downloads/physfs-2.0.0.tar.gz"
+MD5SUM="cfc53e0c193914c9c5ab522e58737373"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Erik Hanson"
EMAIL="erik@slackbuilds.org"
-APPROVED="rworkman"
+APPROVED="dsomero"