summaryrefslogtreecommitdiffstats
path: root/libraries/nltk
diff options
context:
space:
mode:
author ArTourter2018-01-05 02:12:56 +0100
committer Willy Sudiarto Raharjo2018-01-06 00:41:47 +0100
commit4e9c5abf548f5bca53d15e9e9f4e2851cc0840a1 (patch)
tree208438a6fa355c5cbcb96b449dbd653282b25886 /libraries/nltk
parent35df6fedd7167f8804346a66a5a349d079515736 (diff)
downloadslackbuilds-4e9c5abf548f5bca53d15e9e9f4e2851cc0840a1.tar.gz
libraries/nltk: Updated for version 3.2.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/nltk')
-rw-r--r--libraries/nltk/README9
-rw-r--r--libraries/nltk/nltk.SlackBuild16
-rw-r--r--libraries/nltk/nltk.info6
3 files changed, 19 insertions, 12 deletions
diff --git a/libraries/nltk/README b/libraries/nltk/README
index c04df602b5..e47befeee7 100644
--- a/libraries/nltk/README
+++ b/libraries/nltk/README
@@ -1,6 +1,9 @@
-Open source Python modules, linguistic data and documentation for research
-and development in natural language processing, supporting dozens of NLP
-tasks, with distributions for Windows, Mac OSX and Linux.
+Open source Python modules, linguistic data and documentation for research and
+development in natural language processing, supporting dozens of NLP tasks,
+with distributions for Windows, Mac OSX and Linux.
+
+This SlackBuild will create a package with the python2 version and the python3
+version if python3 is installed on the machine.
NLTK comes with many corpora, toy grammars, trained models, etc. A complete
list is posted at: http://nltk.org/nltk_data/. To retrieve all the data, use
diff --git a/libraries/nltk/nltk.SlackBuild b/libraries/nltk/nltk.SlackBuild
index c6ed12e45c..6900e891da 100644
--- a/libraries/nltk/nltk.SlackBuild
+++ b/libraries/nltk/nltk.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nltk
-VERSION=${VERSION:-3.2.1}
+VERSION=${VERSION:-3.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,12 +53,16 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+
+if $(command -v python3 &>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/nltk/nltk.info b/libraries/nltk/nltk.info
index cb697b7bf1..58ce9d3a0e 100644
--- a/libraries/nltk/nltk.info
+++ b/libraries/nltk/nltk.info
@@ -1,8 +1,8 @@
PRGNAM="nltk"
-VERSION="3.2.1"
+VERSION="3.2.5"
HOMEPAGE="http://www.nltk.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/n/nltk/nltk-3.2.1.tar.gz"
-MD5SUM="27d84d2d11449d709ccd1deac18deb05"
+DOWNLOAD="https://pypi.python.org/packages/cc/87/76e691bbf1759ad6af5831649aae6a8d2fa184a1bcc71018ca6300399e5f/nltk-3.2.5.tar.gz"
+MD5SUM="73a33f58da26a18e8d40ef630a40b599"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""