summaryrefslogtreecommitdiffstats
path: root/libraries/nltk/nltk.SlackBuild
diff options
context:
space:
mode:
author ArTourter2018-01-05 02:12:56 +0100
committer Willy Sudiarto Raharjo2018-01-06 00:41:47 +0100
commit4e9c5abf548f5bca53d15e9e9f4e2851cc0840a1 (patch)
tree208438a6fa355c5cbcb96b449dbd653282b25886 /libraries/nltk/nltk.SlackBuild
parent35df6fedd7167f8804346a66a5a349d079515736 (diff)
downloadslackbuilds-4e9c5abf548f5bca53d15e9e9f4e2851cc0840a1.tar.gz
libraries/nltk: Updated for version 3.2.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/nltk/nltk.SlackBuild')
-rw-r--r--libraries/nltk/nltk.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/libraries/nltk/nltk.SlackBuild b/libraries/nltk/nltk.SlackBuild
index c6ed12e45c..6900e891da 100644
--- a/libraries/nltk/nltk.SlackBuild
+++ b/libraries/nltk/nltk.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=nltk
-VERSION=${VERSION:-3.2.1}
+VERSION=${VERSION:-3.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,12 +53,16 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+
+if $(command -v python3 &>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true