summaryrefslogtreecommitdiffstats
path: root/libraries/munkres
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-20 11:35:47 +0100
committer Erik Hanson2014-01-30 06:20:27 +0100
commita9a55f2973d5bbf04dfbbbf7336d4b295b4c96b1 (patch)
tree9e3ea2b6926dd7558f83175b71996d3ad228dcc8 /libraries/munkres
parent73da4d1c1dbd004da9e1956667c44e4925fdfc05 (diff)
downloadslackbuilds-a9a55f2973d5bbf04dfbbbf7336d4b295b4c96b1.tar.gz
libraries/munkres: Added (Munkres algorithm in python).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries/munkres')
-rw-r--r--libraries/munkres/README12
-rw-r--r--libraries/munkres/munkres.SlackBuild90
-rw-r--r--libraries/munkres/munkres.info10
-rw-r--r--libraries/munkres/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/libraries/munkres/README b/libraries/munkres/README
new file mode 100644
index 0000000000..bd6def1299
--- /dev/null
+++ b/libraries/munkres/README
@@ -0,0 +1,12 @@
+The Munkres module provides an implementation of the Munkres algorithm
+(also called the Hungarian algorithm or the Kuhn-Munkres algorithm).
+The algorithm models an assignment problem as an NxM cost matrix,
+where each element represents the cost of assigning the i-th worker to
+j-th job, and it figures out the least-cost solution, choosing a
+single item from each row and column in the matrix, such that no row
+and no column are used more than once.
+
+If you want to build this for use with Python 3.x (needs the
+optional dependency python3) pass the script PYTHON3=yes, like
+
+ PYTHON3=yes ./munkres.SlackBuild
diff --git a/libraries/munkres/munkres.SlackBuild b/libraries/munkres/munkres.SlackBuild
new file mode 100644
index 0000000000..657e766c8d
--- /dev/null
+++ b/libraries/munkres/munkres.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for munkres
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=munkres
+VERSION=${VERSION:-1.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+$PYTHON setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG LICENSE \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/munkres/munkres.info b/libraries/munkres/munkres.info
new file mode 100644
index 0000000000..9a42fedc66
--- /dev/null
+++ b/libraries/munkres/munkres.info
@@ -0,0 +1,10 @@
+PRGNAM="munkres"
+VERSION="1.0.6"
+HOMEPAGE="http://software.clapper.org/munkres/"
+DOWNLOAD="https://pypi.python.org/packages/source/m/munkres/munkres-1.0.6.tar.gz"
+MD5SUM="d7ba3b8c5001578ae229a2d5a655872f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/munkres/slack-desc b/libraries/munkres/slack-desc
new file mode 100644
index 0000000000..af9b7d7231
--- /dev/null
+++ b/libraries/munkres/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+munkres: munkres (Munkres algorithm for the Assignment Problem)
+munkres:
+munkres: The Munkres module provides an implementation of the Munkres
+munkres: algorithm (also called the Hungarian algorithm or the Kuhn-Munkres
+munkres: algorithm), useful for solving the Assignment Problem.
+munkres:
+munkres: homepage: http://software.clapper.org/munkres/
+munkres:
+munkres:
+munkres:
+munkres: