summaryrefslogtreecommitdiffstats
path: root/libraries/mechanize
diff options
context:
space:
mode:
author Larry Hajali2010-05-12 23:30:49 +0200
committer David Somero2010-05-12 23:30:49 +0200
commitf64e694f73542fd765f6a4f57d000ccb3def991c (patch)
treec0d1b8d3fcc0058b898320f07e2d99d1cac8aaa9 /libraries/mechanize
parentcd62ef307555ad7d15899cb8e175a3824f60d960 (diff)
downloadslackbuilds-f64e694f73542fd765f6a4f57d000ccb3def991c.tar.gz
libraries/mechanize: Added to 12.2 repository
Diffstat (limited to 'libraries/mechanize')
-rw-r--r--libraries/mechanize/README4
-rw-r--r--libraries/mechanize/mechanize.SlackBuild51
-rw-r--r--libraries/mechanize/mechanize.info8
-rw-r--r--libraries/mechanize/slack-desc19
4 files changed, 82 insertions, 0 deletions
diff --git a/libraries/mechanize/README b/libraries/mechanize/README
new file mode 100644
index 0000000000..35a75ec97a
--- /dev/null
+++ b/libraries/mechanize/README
@@ -0,0 +1,4 @@
+Stateful programmatic web browsing in Python, after Andy Lester's
+Perl module WWW::Mechanize.
+
+This requires pysetuptools and ClientForm.
diff --git a/libraries/mechanize/mechanize.SlackBuild b/libraries/mechanize/mechanize.SlackBuild
new file mode 100644
index 0000000000..05d4d25e3b
--- /dev/null
+++ b/libraries/mechanize/mechanize.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+# Slackware build script for mechanize
+# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+
+PRGNAM=mechanize
+VERSION=${VERSION:-0.1.11}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Use the system's pysetuptools
+sed -i '/ez_setup/d' setup.py
+
+python setup.py install --root=$PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt *.html $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/mechanize/mechanize.info b/libraries/mechanize/mechanize.info
new file mode 100644
index 0000000000..284995b0da
--- /dev/null
+++ b/libraries/mechanize/mechanize.info
@@ -0,0 +1,8 @@
+PRGNAM="mechanize"
+VERSION="0.1.11"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/"
+DOWNLOAD="http://wwwsearch.sourceforge.net/mechanize/src/mechanize-0.1.11.tar.gz"
+MD5SUM="c5e89a1886e44bd7a8598b0ba47287af"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
+APPROVED="dsomero,rworkman"
diff --git a/libraries/mechanize/slack-desc b/libraries/mechanize/slack-desc
new file mode 100644
index 0000000000..b1a8019384
--- /dev/null
+++ b/libraries/mechanize/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mechanize: mechanize (Stateful programmatic web browsing in Python)
+mechanize:
+mechanize: Stateful programmatic web browsing in Python, after Andy Lester's
+mechanize: Perl module WWW::Mechanize.
+mechanize:
+mechanize: Homepage: http://wwwsearch.sourceforge.net/mechanize/
+mechanize:
+mechanize:
+mechanize:
+mechanize:
+mechanize: