summaryrefslogtreecommitdiffstats
path: root/libraries/luasec
diff options
context:
space:
mode:
author Andrwe Tkalia2013-04-27 21:24:16 +0200
committer Niels Horn2013-04-27 21:24:16 +0200
commitd12e5fc8389ca252417b8966fca4d47d97214a33 (patch)
tree0d1462652c0e4c881a4bcf64cacbd4a98f448c4a /libraries/luasec
parent559f7259c2a2bce6537af82760ae37ab4741c45a (diff)
downloadslackbuilds-d12e5fc8389ca252417b8966fca4d47d97214a33.tar.gz
libraries/luasec: Added (A Lua binding for OpenSSL library)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'libraries/luasec')
-rw-r--r--libraries/luasec/README4
-rw-r--r--libraries/luasec/luasec.SlackBuild104
-rw-r--r--libraries/luasec/luasec.info10
-rw-r--r--libraries/luasec/slack-desc19
4 files changed, 137 insertions, 0 deletions
diff --git a/libraries/luasec/README b/libraries/luasec/README
new file mode 100644
index 0000000000..ef4629b1b0
--- /dev/null
+++ b/libraries/luasec/README
@@ -0,0 +1,4 @@
+A binding for OpenSSL library to provide TLS/SSL communication over
+LuaSocket. This version delegates to LuaSocket the TCP connection
+establishment between the client and server. Then LuaSec uses this
+connection to start a secure TLS/SSL session.
diff --git a/libraries/luasec/luasec.SlackBuild b/libraries/luasec/luasec.SlackBuild
new file mode 100644
index 0000000000..4742d99d36
--- /dev/null
+++ b/libraries/luasec/luasec.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for luasec
+
+# Copyright 2013, Andrew Tkalia <anddt@yandex.ru>, Ukraine, Kyiv
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=luasec
+VERSION=${VERSION:-0.4.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cd src
+# Getting default cflags from config then append slkcflags to them and passing to make
+_CFLAGS=`cat Makefile |grep ^LNX_CFLAGS |sed "s,LNX_CFLAGS\=,,g"`" "${SLKCFLAGS}
+_DEFS=`cat ../Makefile |grep ^DEFS |sed "s,DEFS\=,,g"`
+make linux \
+ LUAPATH=/usr/share/lua/5.1 \
+ LUACPATH=/usr/lib${LIBDIRSUFFIX}/lua/5.1 \
+ DEFS="$_DEFS" \
+ LNX_CFLAGS=" $_CFLAGS"
+mkdir -p $PKG/usr/share/lua/5.1
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/lua/5.1
+
+# Installing:
+make install \
+ LUAPATH=$PKG/usr/share/lua/5.1 \
+ LUACPATH=$PKG/usr/lib${LIBDIRSUFFIX}/lua/5.1
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG INSTALL LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+tar zcvf $PKG/usr/doc/$PRGNAM-$VERSION/samples.tar.gz samples
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/luasec/luasec.info b/libraries/luasec/luasec.info
new file mode 100644
index 0000000000..3aa3262d87
--- /dev/null
+++ b/libraries/luasec/luasec.info
@@ -0,0 +1,10 @@
+PRGNAM="luasec"
+VERSION="0.4.1"
+HOMEPAGE="https://github.com/brunoos/luasec"
+DOWNLOAD="https://github.com/brunoos/luasec/archive/luasec-0.4.1.tar.gz"
+MD5SUM="f6f92d93fb3310aadf2ede5d3e8dea53"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lua"
+MAINTAINER="Andrwe Tkalia"
+EMAIL="anddt@yandex.ru"
diff --git a/libraries/luasec/slack-desc b/libraries/luasec/slack-desc
new file mode 100644
index 0000000000..b223a49f9b
--- /dev/null
+++ b/libraries/luasec/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+luasec: luasec (A Lua binding for OpenSSL library)
+luasec:
+luasec: A binding for OpenSSL library to provide TLS/SSL communication over
+luasec: LuaSocket. This version delegates to LuaSocket the TCP connection
+luasec: establishment between the client and server. Then LuaSec uses this
+luasec: connection to start a secure TLS/SSL session.
+luasec:
+luasec:
+luasec:
+luasec:
+luasec: