summaryrefslogtreecommitdiffstats
path: root/libraries/logilab-common
diff options
context:
space:
mode:
author grissiom2010-05-12 23:30:48 +0200
committer David Somero2010-05-12 23:30:48 +0200
commit25215c1ac8a7c54468f2c73b85df6922cf922a81 (patch)
treec103a06637d0547a975e1c08f69c8dc198d05a1d /libraries/logilab-common
parenta0144c7e726638f1023431afd3aaf2cf91577254 (diff)
downloadslackbuilds-25215c1ac8a7c54468f2c73b85df6922cf922a81.tar.gz
libraries/logilab-common: Added to 12.2 repository
Diffstat (limited to 'libraries/logilab-common')
-rw-r--r--libraries/logilab-common/README14
-rw-r--r--libraries/logilab-common/logilab-common.SlackBuild45
-rw-r--r--libraries/logilab-common/logilab-common.info8
-rw-r--r--libraries/logilab-common/slack-desc19
4 files changed, 86 insertions, 0 deletions
diff --git a/libraries/logilab-common/README b/libraries/logilab-common/README
new file mode 100644
index 0000000000..c9a239cb65
--- /dev/null
+++ b/libraries/logilab-common/README
@@ -0,0 +1,14 @@
+logilab-common is a collection of useful miscellaneous modules used by
+Logilab projects designed to ease:
+
+ * handling command line options and configuration files
+ * writing interactive command line tools
+ * manipulation files and character strings
+ * interfacing to OmniORB
+ * generating of SQL queries
+ * running unit tests
+ * manipulating tree structures
+ * accessing RDBMS (currently postgreSQL, MySQL and sqlite)
+ * generating text and HTML reports
+ * loggingThis package contains some modules used by different
+ Logilab's projects.
diff --git a/libraries/logilab-common/logilab-common.SlackBuild b/libraries/logilab-common/logilab-common.SlackBuild
new file mode 100644
index 0000000000..c6df940fb0
--- /dev/null
+++ b/libraries/logilab-common/logilab-common.SlackBuild
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+# Slackware build script for logilab-common
+
+# Written by Grissiom chaos.proton@gmail.com
+
+PRGNAM=logilab-common
+VERSION=${VERSION:-0.39.0}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
+rm -rf ${PKG}/usr/share
+
+cp PKG-INFO README ChangeLog COPYING DEPENDS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/logilab-common/logilab-common.info b/libraries/logilab-common/logilab-common.info
new file mode 100644
index 0000000000..449f953d8e
--- /dev/null
+++ b/libraries/logilab-common/logilab-common.info
@@ -0,0 +1,8 @@
+PRGNAM="logilab-common"
+VERSION="0.39.0"
+HOMEPAGE="http://www.logilab.org/project/logilab-common"
+DOWNLOAD="http://ftp.logilab.org/pub/common/logilab-common-0.39.0.tar.gz"
+MD5SUM="9b49a710eb08225919aceedb84f1f28c"
+MAINTAINER="grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/logilab-common/slack-desc b/libraries/logilab-common/slack-desc
new file mode 100644
index 0000000000..4347109e6c
--- /dev/null
+++ b/libraries/logilab-common/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+logilab-common: logilab-common (Python modules used by Logilab's projects)
+logilab-common:
+logilab-common: logilab-common is a collection of useful miscellaneous modules used
+logilab-common: by Logilab projects. It is released under the GNU Public License.
+logilab-common:
+logilab-common:
+logilab-common: Homepage: http://www.logilab.org/848/
+logilab-common:
+logilab-common:
+logilab-common:
+logilab-common: