summaryrefslogtreecommitdiffstats
path: root/libraries/logilab-astng
diff options
context:
space:
mode:
author grissiom2010-05-12 23:30:48 +0200
committer David Somero2010-05-12 23:30:48 +0200
commita0144c7e726638f1023431afd3aaf2cf91577254 (patch)
tree14c5598dff377a3d7a31b748caac76cb54bc542f /libraries/logilab-astng
parentf4cd4156cf1cb6852fb889bef8a710ac048b8c92 (diff)
downloadslackbuilds-a0144c7e726638f1023431afd3aaf2cf91577254.tar.gz
libraries/logilab-astng: Added to 12.2 repository
Diffstat (limited to 'libraries/logilab-astng')
-rw-r--r--libraries/logilab-astng/README23
-rw-r--r--libraries/logilab-astng/logilab-astng.SlackBuild45
-rw-r--r--libraries/logilab-astng/logilab-astng.info8
-rw-r--r--libraries/logilab-astng/slack-desc19
4 files changed, 95 insertions, 0 deletions
diff --git a/libraries/logilab-astng/README b/libraries/logilab-astng/README
new file mode 100644
index 0000000000..9312185de8
--- /dev/null
+++ b/libraries/logilab-astng/README
@@ -0,0 +1,23 @@
+The aim of this module is to provide a common base representation of
+python source code for projects such as pychecker, pyreverse,
+pylint... Well, actually the development of this library is essentially
+governed by pylint's needs.
+
+It extends class defined in the compiler.ast [1] module with some
+additional methods and attributes. Instance attributes are added by a
+builder object, which can either generate extended ast (let's call
+them astng ;) by visiting an existant ast tree or by inspecting living
+object. Methods are added by monkey patching ast classes.
+
+Main modules are:
+
+* nodes and scoped_nodes for more information about methods and
+ attributes added to different node classes
+
+* the manager contains a high level object to get astng trees from
+ source files and living objects. It maintains a cache of previously
+ constructed tree for quick access
+
+* builder contains the class responsible to build astng trees
+
+Dependences: logilab-common available at SlackBuilds.org \ No newline at end of file
diff --git a/libraries/logilab-astng/logilab-astng.SlackBuild b/libraries/logilab-astng/logilab-astng.SlackBuild
new file mode 100644
index 0000000000..56ebcffaef
--- /dev/null
+++ b/libraries/logilab-astng/logilab-astng.SlackBuild
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+# Slackware build script for logilab-astng
+
+# Written by Grissiom chaos.proton@gmail.com
+
+PRGNAM=logilab-astng
+VERSION=${VERSION:-0.19.0}
+ARCH=${ARCH:-noarch}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p ${PKG}/usr/doc/$PRGNAM-$VERSION
+rm -rf ${PKG}/usr/share
+
+cp PKG-INFO README ChangeLog COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/logilab-astng/logilab-astng.info b/libraries/logilab-astng/logilab-astng.info
new file mode 100644
index 0000000000..fcf113c1f1
--- /dev/null
+++ b/libraries/logilab-astng/logilab-astng.info
@@ -0,0 +1,8 @@
+PRGNAM="logilab-astng"
+VERSION="0.19.0"
+HOMEPAGE="http://www.logilab.org/project/logilab-astng"
+DOWNLOAD="http://ftp.logilab.org/pub/astng/logilab-astng-0.19.0.tar.gz"
+MD5SUM="9478141bd45c1a1e72621797c94f18d3"
+MAINTAINER="grissiom"
+EMAIL="chaos.proton@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/logilab-astng/slack-desc b/libraries/logilab-astng/slack-desc
new file mode 100644
index 0000000000..cde8369f67
--- /dev/null
+++ b/libraries/logilab-astng/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+logilab-astng: logilab-astng (Python modules used by many python code checkers)
+logilab-astng:
+logilab-astng: The aim of this module is to provide a common base representation of
+logilab-astng: python source code for projects such as pychecker, pyreverse,
+logilab-astng: pylint.
+logilab-astng:
+logilab-astng: Homepage:http://logilab-common.sourceforge.net/
+logilab-astng:
+logilab-astng:
+logilab-astng:
+logilab-astng: