summaryrefslogtreecommitdiffstats
path: root/libraries/libixp
diff options
context:
space:
mode:
author Antonio Hernández Blas2010-05-11 22:24:00 +0200
committer David Somero2010-05-11 22:24:00 +0200
commit0c21baef3b662b0b189e226e26b9b015d5d5f3b9 (patch)
tree5a0a1e4362b1188caa7a2b2a7e87f8ca2179cd85 /libraries/libixp
parent93858dda25ec8234ae0a983886d70b33a33e27d9 (diff)
downloadslackbuilds-0c21baef3b662b0b189e226e26b9b015d5d5f3b9.tar.gz
libraries/libixp: Updated for version 0.4
Diffstat (limited to 'libraries/libixp')
-rw-r--r--libraries/libixp/libixp.SlackBuild75
-rw-r--r--libraries/libixp/libixp.info12
2 files changed, 61 insertions, 26 deletions
diff --git a/libraries/libixp/libixp.SlackBuild b/libraries/libixp/libixp.SlackBuild
index dc9d73397a..5085cb154e 100644
--- a/libraries/libixp/libixp.SlackBuild
+++ b/libraries/libixp/libixp.SlackBuild
@@ -1,15 +1,32 @@
#!/bin/sh
# Slackware build script for libixp
-# Written by core <eroc@linuxmail.org>
-# Modified by the SlackBuilds.org project
+# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+# 1.- Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=libixp
-VERSION=0.2
+VERSION=0.4
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
@@ -19,39 +36,57 @@ if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
fi
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
+cd $TMP
rm -rf $PRGNAM-$VERSION
-tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz || exit 1
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-
chown -R root:root .
-chmod -R a-s,u+rw,go-w .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
-# Fix the prefix
-sed -i 's%PREFIX = /usr/local%PREFIX = /usr%' config.mk || exit 1
-# ... and the CFLAGS
-sed -i 's/CFLAGS = -Os /CFLAGS += /g' config.mk || exit 1
+# Fix prefixes and cflags values
+sed -i \
+ -e 's:^PREFIX = /usr/local:PREFIX = /usr:' \
+ -e 's:^MAN = ${PREFIX}/share/man:MAN = /usr/man:' \
+ -e 's:^ETC = ${PREFIX}/etc:ETC = /etc:' \
+ -e 's:^CFLAGS =:CFLAGS += :' \
+ config.mk
+CFLAGS="$SLKCFLAGS" make
-CFLAGS="$SLKCFLAGS" make || exit 1
-make install DESTDIR=$PKG || exit 1
+# This is *needed* to install correctly under $PKG
+sed -i \
+ -e 's:^PREFIX = /usr:PREFIX = '${PKG}'/usr:' \
+ -e 's:^MAN = /usr/man:MAN = '${PKG}'/usr/man:' \
+ -e 's:^ETC = /etc:ETC = '${PKG}'/etc:' \
+ config.mk
+make install
-find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+# Erase "/etc", it's empty
+rmdir $PKG/etc
-# Move the man pages to the correct location
-mv $PKG/usr/share/man $PKG/usr
-rmdir $PKG/usr/share
+(
+ find $PKG | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ find $PKG | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+)
-( cd $PKG/usr/man || exit
+( cd $PKG/usr/man
find . -type f -exec gzip -9 {} \;
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cd libixp
cp -a LICENSE LICENSE.p9p README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/libraries/libixp/libixp.info b/libraries/libixp/libixp.info
index 9cfdd3fa2b..fd8a618bf5 100644
--- a/libraries/libixp/libixp.info
+++ b/libraries/libixp/libixp.info
@@ -1,8 +1,8 @@
PRGNAM="libixp"
-VERSION="0.2"
+VERSION="0.4"
HOMEPAGE="http://www.suckless.org/wiki/libs/libixp"
-DOWNLOAD="http://libs.suckless.org/download/libixp-0.2.tar.gz"
-MD5SUM="e50c613f7410bc1cff3a18926804202f"
-MAINTAINER="core"
-EMAIL="eroc@linuxmail.org"
-APPROVED="rworkman"
+DOWNLOAD="http://www.suckless.org/download/libixp-0.4.tar.gz"
+MD5SUM="59d9e918adffaf4413b32ac4f66724fd"
+MAINTAINER="Antonio Hernández Blas"
+EMAIL="hba.nihilismus@gmail.com"
+APPROVED="David Somero"