summaryrefslogtreecommitdiffstats
path: root/libraries/libgta
diff options
context:
space:
mode:
author Christoph Willing2018-05-23 01:28:57 +0200
committer Willy Sudiarto Raharjo2018-05-26 01:59:24 +0200
commit8c9de37fc99ea78fa09a6f66782dce441efa82e1 (patch)
treec571b80aa4011c4684099ad5e21697986848e83a /libraries/libgta
parent3328a62981d8a1473d2a7343829157b1ea112b68 (diff)
downloadslackbuilds-8c9de37fc99ea78fa09a6f66782dce441efa82e1.tar.gz
libraries/libgta: Added (Generic Tagged Arrays Library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'libraries/libgta')
-rw-r--r--libraries/libgta/README7
-rw-r--r--libraries/libgta/libgta.SlackBuild99
-rw-r--r--libraries/libgta/libgta.info10
-rw-r--r--libraries/libgta/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/libraries/libgta/README b/libraries/libgta/README
new file mode 100644
index 0000000000..3b212778fc
--- /dev/null
+++ b/libraries/libgta/README
@@ -0,0 +1,7 @@
+The GTA project provides a file format called Generic Tagged Arrays that
+- is very easy to use
+- can store any kind of multidimensional array data
+- allows generic manipulations of array data
+- allows conversion to and from other file formats
+
+This libgta package is an optional requirement for OpenSceneGraph.
diff --git a/libraries/libgta/libgta.SlackBuild b/libraries/libgta/libgta.SlackBuild
new file mode 100644
index 0000000000..da5ce1b81b
--- /dev/null
+++ b/libraries/libgta/libgta.SlackBuild
@@ -0,0 +1,99 @@
+#!/bin/sh
+
+# Slackware build script for libgta
+
+# Copyright 2018 Christoph Willing, Brisbane Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libgta
+VERSION=${VERSION:-1.0.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
+cd $PRGNAM-$VERSION
+sed -i -e 's:share/doc/libgta:doc/libgta-${GTA_VERSION}:' CMakeLists.txt
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DGTA_BUILD_DOCUMENTATION=ON \
+ -DGTA_BUILD_SHARED_LIB=ON \
+ -DGTA_BUILD_STATIC_LIB=OFF \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libgta/libgta.info b/libraries/libgta/libgta.info
new file mode 100644
index 0000000000..ae4fe431b1
--- /dev/null
+++ b/libraries/libgta/libgta.info
@@ -0,0 +1,10 @@
+PRGNAM="libgta"
+VERSION="1.0.8"
+HOMEPAGE="http://gta.nongnu.org/"
+DOWNLOAD="http://download-mirror.savannah.gnu.org/releases/gta/libgta-1.0.8.tar.xz"
+MD5SUM="0012d064c9aca88c916081717b7f1511"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@linux.com"
diff --git a/libraries/libgta/slack-desc b/libraries/libgta/slack-desc
new file mode 100644
index 0000000000..a79ccea4ac
--- /dev/null
+++ b/libraries/libgta/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libgta: libgta (Generic Tagged Arrays Library)
+libgta:
+libgta: The GTA project provides a Generic Tagged Arrays file format that
+libgta: - is very easy to use
+libgta: - can store any kind of multidimensional array data
+libgta: - allows generic manipulations of array data
+libgta: - allows conversion to and from other file formats
+libgta:
+libgta:
+libgta: This libgta package is an optional requirement for OpenSceneGraph.
+libgta: