summaryrefslogtreecommitdiffstats
path: root/libraries/libearth
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-15 03:15:10 +0100
committer Erik Hanson2014-01-30 06:21:02 +0100
commitb1caad72a152b6f4918d108a5af116ef3e28dff1 (patch)
treef3226bc9a03dbd7c93b9a18a72f424a2bcbe35e3 /libraries/libearth
parent7156e1be438f29a1bbc52d525db503af6acb8156 (diff)
downloadslackbuilds-b1caad72a152b6f4918d108a5af116ef3e28dff1.tar.gz
libraries/libearth: Added (shared library for Earth Reader apps).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libearth')
-rw-r--r--libraries/libearth/README8
-rw-r--r--libraries/libearth/libearth.SlackBuild85
-rw-r--r--libraries/libearth/libearth.info11
-rw-r--r--libraries/libearth/slack-desc19
4 files changed, 123 insertions, 0 deletions
diff --git a/libraries/libearth/README b/libraries/libearth/README
new file mode 100644
index 0000000000..fcc8d6949e
--- /dev/null
+++ b/libraries/libearth/README
@@ -0,0 +1,8 @@
+The shared common library for Earth Reader apps.
+
+Libearth is the shared common library for various Earth Reader apps.
+Earth Reader try to support many platforms as possible (e.g. web,
+mobile apps, desktop apps), so there must be a large part of common
+concepts and implementations they share like subscription lists,
+synchronization through cloud storages between several devices,
+and crawler, that libearth actually implements.
diff --git a/libraries/libearth/libearth.SlackBuild b/libraries/libearth/libearth.SlackBuild
new file mode 100644
index 0000000000..c5bedcaa8c
--- /dev/null
+++ b/libraries/libearth/libearth.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for libearth
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libearth
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libearth/libearth.info b/libraries/libearth/libearth.info
new file mode 100644
index 0000000000..e179daae77
--- /dev/null
+++ b/libraries/libearth/libearth.info
@@ -0,0 +1,11 @@
+PRGNAM="libearth"
+VERSION="0.1.1"
+HOMEPAGE="http://libearth.earthreader.org/en/0.1.1/"
+DOWNLOAD="https://pypi.python.org/packages/source/l/libearth/libearth-0.1.1.tar.gz"
+MD5SUM="62f524d9f8fd3b251d7a45623e012b27"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
+
diff --git a/libraries/libearth/slack-desc b/libraries/libearth/slack-desc
new file mode 100644
index 0000000000..ddebed1457
--- /dev/null
+++ b/libraries/libearth/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libearth: libearth (The shared common library for Earth Reader apps)
+libearth:
+libearth: Libearth is the shared common library for various Earth Reader apps.
+libearth: Earth Reader try to support many platforms as possible (e.g. web,
+libearth: mobile apps, desktop apps), so there must be a large part of common
+libearth: concepts and implementations they share like subscription lists,
+libearth: synchronization through cloud storages between several devices,
+libearth: and crawler, that libearth actually implements.
+libearth:
+libearth: Homepage: http://libearth.earthreader.org/en/0.1.1/
+libearth: