summaryrefslogtreecommitdiffstats
path: root/libraries/libaaio/libaaio.SlackBuild
diff options
context:
space:
mode:
author A. Green2016-05-04 05:19:56 +0200
committer Willy Sudiarto Raharjo2016-05-04 06:52:07 +0200
commitce1b6dd273244cc7f3d836b47b74e232703b047b (patch)
tree76743ed76c7d126681fdbcb9fda030efeb06d2fd /libraries/libaaio/libaaio.SlackBuild
parente42a8548bfa3f745ebea41edd44e8d813562224b (diff)
downloadslackbuilds-ce1b6dd273244cc7f3d836b47b74e232703b047b.tar.gz
libraries/libaaio: fixes for crusty autoconf.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/libaaio/libaaio.SlackBuild')
-rw-r--r--libraries/libaaio/libaaio.SlackBuild46
1 files changed, 28 insertions, 18 deletions
diff --git a/libraries/libaaio/libaaio.SlackBuild b/libraries/libaaio/libaaio.SlackBuild
index e249b50d31..88a0ab4909 100644
--- a/libraries/libaaio/libaaio.SlackBuild
+++ b/libraries/libaaio/libaaio.SlackBuild
@@ -1,32 +1,34 @@
#!/bin/sh -e
-# SlackBuild for libaaio, 9 March 2016
+# SlackBuild for libaaio, 3 May 2016
# Arthur W. Green <lynx@panix.com>
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Redistribution and use of this script, with or without modification,
+# is permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# libaaio itself remains a copyrighted work. Please see the file COPYING
-# or README in the libaaio source distribution for more on this.
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
+# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+## libaaio itself remains a copyrighted work. Please see the file
+## COPYING or README in the libaaio source distribution for more on
+## this.
PRGNAM=libaaio
VERSION=${VERSION:-0.3.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -67,6 +69,14 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . -exec chmod -R u+w,go-w,a+rX-st {} \;
+# twiddle and patch files to appease crusty autoconf.
+mv -v configure.in configure.ac
+patch -p1 < $CWD/$PRGNAM.patch
+mkdir -p m4 # a stub.
+autoreconf --install --force
+
+# build BOTH static and shared libraries, as software dependent
+# on libaaio expect libaaio.a more often than not.
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -75,7 +85,7 @@ CXXFLAGS="$SLKCFLAGS" \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
- --disable-static \
+ --enable-static \
--enable-shared \
--build=$ARCH-slackware-linux