summaryrefslogtreecommitdiffstats
path: root/libraries/ipaddress
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2014-01-23 10:48:22 +0100
committer Erik Hanson2014-01-30 06:21:11 +0100
commit2b1c0bcddaba1378039cc7570061180424036d4c (patch)
tree204dd8f7584318c3b6078377e96a69afd1de93f1 /libraries/ipaddress
parentab39307833e25819ff748e0777b34514b0b6751d (diff)
downloadslackbuilds-2b1c0bcddaba1378039cc7570061180424036d4c.tar.gz
libraries/ipaddress: Added (IPv4/IPv6 manipulation library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/ipaddress')
-rw-r--r--libraries/ipaddress/README4
-rw-r--r--libraries/ipaddress/ipaddress.SlackBuild85
-rw-r--r--libraries/ipaddress/ipaddress.info10
-rw-r--r--libraries/ipaddress/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/libraries/ipaddress/README b/libraries/ipaddress/README
new file mode 100644
index 0000000000..3d79f23dbf
--- /dev/null
+++ b/libraries/ipaddress/README
@@ -0,0 +1,4 @@
+Python 3.3's ipaddress for Python 2.6 and 2.7.
+
+Note that you must pass in unicode objects when constructing
+from a character representation!
diff --git a/libraries/ipaddress/ipaddress.SlackBuild b/libraries/ipaddress/ipaddress.SlackBuild
new file mode 100644
index 0000000000..dab4270e2c
--- /dev/null
+++ b/libraries/ipaddress/ipaddress.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for ipaddress
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ipaddress
+VERSION=${VERSION:-1.0.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ipaddress/ipaddress.info b/libraries/ipaddress/ipaddress.info
new file mode 100644
index 0000000000..f4cb9b1b31
--- /dev/null
+++ b/libraries/ipaddress/ipaddress.info
@@ -0,0 +1,10 @@
+PRGNAM="ipaddress"
+VERSION="1.0.6"
+HOMEPAGE="https://github.com/phihag/ipaddress"
+DOWNLOAD="https://pypi.python.org/packages/source/i/ipaddress/ipaddress-1.0.6.tar.gz"
+MD5SUM="a869a0c03f03961c714046a579e38e68"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/ipaddress/slack-desc b/libraries/ipaddress/slack-desc
new file mode 100644
index 0000000000..f243a3fb07
--- /dev/null
+++ b/libraries/ipaddress/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ipaddress: ipaddress (IPv4/IPv6 manipulation library)
+ipaddress:
+ipaddress: Port of the Python 3.3+ ipaddress module to 2.6 and 2.7
+ipaddress:
+ipaddress: Homepage: https://github.com/phihag/ipaddress
+ipaddress:
+ipaddress:
+ipaddress:
+ipaddress:
+ipaddress:
+ipaddress: