summaryrefslogtreecommitdiffstats
path: root/libraries/gtksourceview/gtksourceview.SlackBuild
diff options
context:
space:
mode:
author Mikko Värri2012-09-11 15:30:23 +0200
committer Robby Workman2012-09-11 15:44:46 +0200
commit4546743ec059ade0b1a4fffdb2415565e2a59a6c (patch)
treee1cfb8ea3bc5ee9b2deb30a9a11ce00a019bdaf3 /libraries/gtksourceview/gtksourceview.SlackBuild
parent45bde4d181430ef40888fc7b8d52bdafac72f822 (diff)
downloadslackbuilds-4546743ec059ade0b1a4fffdb2415565e2a59a6c.tar.gz
libraries/gtksourceview: Fix several build issues.
Signed-off-by: Mikko Värri <vmj@linuxbox.fi> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/gtksourceview/gtksourceview.SlackBuild')
-rw-r--r--libraries/gtksourceview/gtksourceview.SlackBuild22
1 files changed, 20 insertions, 2 deletions
diff --git a/libraries/gtksourceview/gtksourceview.SlackBuild b/libraries/gtksourceview/gtksourceview.SlackBuild
index 676c1f8a8a..a457b9a056 100644
--- a/libraries/gtksourceview/gtksourceview.SlackBuild
+++ b/libraries/gtksourceview/gtksourceview.SlackBuild
@@ -26,7 +26,7 @@
PRGNAM=gtksourceview
VERSION=${VERSION:-2.11.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -73,6 +73,22 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# In configure.ac, PKG_CONFIG environment variable is used before it
+# is set. Instead of fixing configure.ac and regenerating all of the
+# build framework, let's just monkey patch the configure script.
+patch -p0 <$CWD/fix-pkg-config-use-before-set.patch
+
+# gtksourceview 2.11.2 seems to claim to be compatible with gtk3 =>
+# 2.90, but in reality is not compatible with the one in Slackware
+# 14.0. Let's force the configure script to pick up gtk2 instead by
+# raising the minimum gtk3 version.
+patch -p0 <$CWD/force-gtk2.patch
+
+# Code is still using G_CONST_RETURN which is deprecated in the
+# version of glib shipping with Slackware 14.0. Let's remove the
+# G_DISABLE_DEPRECATED from C preprocessor flags.
+patch -p0 <$CWD/allow-deprecated-glib-symbols.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -85,7 +101,9 @@ CXXFLAGS="$SLKCFLAGS" \
--enable-glade-catalog \
--build=$ARCH-slackware-linux
-make
+# At the end of build process, the uninstalled gtksourceview.pc is
+# used. Let's make sure pkg-config can find it.
+PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$TMP/$PRGNAM-$VERSION make
make install-strip DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \