summaryrefslogtreecommitdiffstats
path: root/libraries/genshi
diff options
context:
space:
mode:
author B. Watson2022-04-19 19:38:52 +0200
committer B. Watson2022-04-19 19:38:52 +0200
commit9dd6332cabc0683386c798ca23427bbadb4a39b7 (patch)
tree695881326231b25a43d5b911c789935b24b6a55a /libraries/genshi
parent29e52ad7789f928447d259738380474dabe873ec (diff)
downloadslackbuilds-9dd6332cabc0683386c798ca23427bbadb4a39b7.tar.gz
libraries/genshi: Strip library.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries/genshi')
-rw-r--r--libraries/genshi/genshi.SlackBuild32
1 files changed, 12 insertions, 20 deletions
diff --git a/libraries/genshi/genshi.SlackBuild b/libraries/genshi/genshi.SlackBuild
index 9398743ff5..951d65fdee 100644
--- a/libraries/genshi/genshi.SlackBuild
+++ b/libraries/genshi/genshi.SlackBuild
@@ -5,26 +5,27 @@
# Maintained by James Geboski <jgeboski@gmail.com>
# now by Matteo Bernardini <ponce@slackbuilds.org>
+# 20220419 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - strip shared library.
+# - i486 => i586.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=genshi
SRCNAM=Genshi
VERSION=${VERSION:-0.7}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -34,19 +35,7 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+# 20220419 bkw: nothing was using SLKCFLAGS, delete...
set -e
@@ -59,12 +48,15 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python setup.py install --root=$PKG
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a doc/* COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild