summaryrefslogtreecommitdiffstats
path: root/libraries/enum34
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-23 09:56:09 +0100
committer Erik Hanson2014-01-30 06:21:11 +0100
commitab39307833e25819ff748e0777b34514b0b6751d (patch)
treeb570b0fc9857f61a853b7cb1c1dc0ccf3b9c9932 /libraries/enum34
parent60a8dd1005a206e042f30ab0eaba554b2598b4f5 (diff)
downloadslackbuilds-ab39307833e25819ff748e0777b34514b0b6751d.tar.gz
libraries/enum34: Added (backported Python 3.4 Enum).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/enum34')
-rw-r--r--libraries/enum34/README2
-rw-r--r--libraries/enum34/enum34.SlackBuild85
-rw-r--r--libraries/enum34/enum34.info10
-rw-r--r--libraries/enum34/slack-desc20
4 files changed, 117 insertions, 0 deletions
diff --git a/libraries/enum34/README b/libraries/enum34/README
new file mode 100644
index 0000000000..511af98413
--- /dev/null
+++ b/libraries/enum34/README
@@ -0,0 +1,2 @@
+enum34 is the new Python stdlib enum module available in Python 3.4
+backported for previous versions of Python from 2.4 to 3.3.
diff --git a/libraries/enum34/enum34.SlackBuild b/libraries/enum34/enum34.SlackBuild
new file mode 100644
index 0000000000..115492af8c
--- /dev/null
+++ b/libraries/enum34/enum34.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for enum34
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=enum34
+VERSION=${VERSION:-0.9.19}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO enum/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/enum34/enum34.info b/libraries/enum34/enum34.info
new file mode 100644
index 0000000000..76039310df
--- /dev/null
+++ b/libraries/enum34/enum34.info
@@ -0,0 +1,10 @@
+PRGNAM="enum34"
+VERSION="0.9.19"
+HOMEPAGE="https://pypi.python.org/pypi/enum34"
+DOWNLOAD="https://pypi.python.org/packages/source/e/enum34/enum34-0.9.19.tar.gz"
+MD5SUM="efb6a497f51e480ed356e976d0369cb3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/enum34/slack-desc b/libraries/enum34/slack-desc
new file mode 100644
index 0000000000..be9d4908d4
--- /dev/null
+++ b/libraries/enum34/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+enum34: enum34 (backported Python 3.4 Enum)
+enum34:
+enum34: An enumeration is a set of symbolic names (members) bound to unique,
+enum34: constant values. Within an enumeration, the members can be compared
+enum34: by identity, and the enumeration itself can be iterated over.
+enum34:
+enum34: Homepage : https://pypi.python.org/pypi/enum34
+enum34:
+enum34:
+enum34:
+enum34:
+enum34: