summaryrefslogtreecommitdiffstats
path: root/libraries/cddb-py
diff options
context:
space:
mode:
author Robby Workman2011-03-16 07:13:49 +0100
committer Robby Workman2011-03-20 18:33:01 +0100
commit7a1b4848a3d34a263544fadf08178c91c12fbad0 (patch)
tree8987d0fc908e371dfa87445425f59c7514075b37 /libraries/cddb-py
parent987d45e99a299c3b24418b2976e8ec9d5f3bf404 (diff)
downloadslackbuilds-7a1b4848a3d34a263544fadf08178c91c12fbad0.tar.gz
python/*: Moved a lot of Python stuff here
The criteria for whether something "belongs" in Development or Libraries or Python or ... is admittedly arbitrary. As a general rule, if it could be either Libraries or Python, it's Python. Otherwise, pick one and we'll go from there... Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries/cddb-py')
-rw-r--r--libraries/cddb-py/README5
-rw-r--r--libraries/cddb-py/cddb-py.SlackBuild73
-rw-r--r--libraries/cddb-py/cddb-py.info10
-rw-r--r--libraries/cddb-py/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/libraries/cddb-py/README b/libraries/cddb-py/README
deleted file mode 100644
index 7bccd8839f..0000000000
--- a/libraries/cddb-py/README
+++ /dev/null
@@ -1,5 +0,0 @@
-This is actually a set of three modules to access the CDDB and FreeDB
-online databases of audio CD track titles and information. It includes a C
-extension module to fetch track lengths under Linux, FreeBSD, OpenBSD, Mac
-OS X, Solaris, and Win32, which is easily ported to other operating systems.
-
diff --git a/libraries/cddb-py/cddb-py.SlackBuild b/libraries/cddb-py/cddb-py.SlackBuild
deleted file mode 100644
index 8d3ce53a9a..0000000000
--- a/libraries/cddb-py/cddb-py.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for cddb-py
-
-# Written by Mihai Militaru <mihai.militaru@gmx.com>
-# March 2009
-
-PRGNAM=cddb-py
-ORIGNAM=CDDB
-VERSION=${VERSION:-1.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="COPYING CHANGES README"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$ORIGNAM.tar.gz
-cd $ORIGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp -a \
- $DOCS \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/cddb-py/cddb-py.info b/libraries/cddb-py/cddb-py.info
deleted file mode 100644
index 57425a15b5..0000000000
--- a/libraries/cddb-py/cddb-py.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="cddb-py"
-VERSION="1.4"
-HOMEPAGE="http://cddb-py.sourceforge.net/"
-DOWNLOAD="http://cddb-py.sourceforge.net/CDDB.tar.gz"
-MD5SUM="254698082bafe3030d07d88fb7e13fe2"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Mihai Militaru"
-EMAIL="mihai.militaru@gmx.com"
-APPROVED="dsomero"
diff --git a/libraries/cddb-py/slack-desc b/libraries/cddb-py/slack-desc
deleted file mode 100644
index 2215028cbc..0000000000
--- a/libraries/cddb-py/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------|
-cddb-py: cddb-py (CDDB and FreeDB audio CD track info access in Python)
-cddb-py:
-cddb-py: This is actually a set of three modules to access the CDDB and
-cddb-py: FreeDB online databases of audio CD track titles and information.
-cddb-py: It includes a C extension module to fetch track lengths under
-cddb-py: Linux, FreeBSD, OpenBSD, Mac OS X, Solaris, and Win32, which is
-cddb-py: easily ported to other operating systems.
-cddb-py:
-cddb-py: Homepage: http://cddb-py.sourceforge.net/
-cddb-py:
-cddb-py: