summaryrefslogtreecommitdiffstats
path: root/libraries/aqbanking
diff options
context:
space:
mode:
author Heiko Rosemann2013-12-29 03:03:29 +0100
committer Erik Hanson2014-01-07 18:13:58 +0100
commit57b97ca1ac8000891d2dbe642efb0662e54b3eac (patch)
treeb026f3f2728640aa8d506ea64a01c32a34973b1c /libraries/aqbanking
parent7070172b7cd794da1e46f405e04a79f5d875bf64 (diff)
downloadslackbuilds-57b97ca1ac8000891d2dbe642efb0662e54b3eac.tar.gz
libraries/aqbanking: Added (library for online banking).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/aqbanking')
-rw-r--r--libraries/aqbanking/README12
-rw-r--r--libraries/aqbanking/aqbanking.SlackBuild104
-rw-r--r--libraries/aqbanking/aqbanking.info10
-rw-r--r--libraries/aqbanking/slack-desc19
4 files changed, 145 insertions, 0 deletions
diff --git a/libraries/aqbanking/README b/libraries/aqbanking/README
new file mode 100644
index 0000000000..62fe2e8cbe
--- /dev/null
+++ b/libraries/aqbanking/README
@@ -0,0 +1,12 @@
+AqBanking (library for online banking)
+
+AqBanking offers an interface to generic online banking tasks,
+bank information for the US, Germany, Austria and Switzerland
+and country- and currency-related information.
+
+AqBanking can be used by AqFinance, OrgaMon, GnuCash and KMyMoney
+It supports HBCI (2.01, 2.10, 2.20, FinTS 3.00), EBICS (2.3 and 2.4)
+and OFX Direct Connect.
+
+Note: To have gnucash (as of 2013-12-28) use AqBanking,
+recompile gnucash with --enable-aqbanking.
diff --git a/libraries/aqbanking/aqbanking.SlackBuild b/libraries/aqbanking/aqbanking.SlackBuild
new file mode 100644
index 0000000000..70c8d60c9d
--- /dev/null
+++ b/libraries/aqbanking/aqbanking.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/sh
+
+# Slackware build script for aqbanking
+
+# Copyright 2013 Heiko Rosemann Germany
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=aqbanking
+VERSION=${VERSION:-5.0.25}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make -j 1
+make -j 1 install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS COPYING ChangeLog INSTALL NEWS README TODO tutorials doc \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+# Remove Makefiles from documentation directories
+rm $PKG/usr/doc/$PRGNAM-$VERSION/doc/Makefile*
+rm $PKG/usr/doc/$PRGNAM-$VERSION/doc/apidoc.h
+rm $PKG/usr/doc/$PRGNAM-$VERSION/tutorials/Makefile*
+
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/aqbanking/aqbanking.info b/libraries/aqbanking/aqbanking.info
new file mode 100644
index 0000000000..de5cbda265
--- /dev/null
+++ b/libraries/aqbanking/aqbanking.info
@@ -0,0 +1,10 @@
+PRGNAM="aqbanking"
+VERSION="5.0.25"
+HOMEPAGE="http://www.aquamaniac.de/sites/aqbanking/index.php"
+DOWNLOAD="http://files.slackware-id.org/aqbanking-5.0.25.tar.gz"
+MD5SUM="b238639962128ce25db81870f65173d9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="%README% gwenhywfar"
+MAINTAINER="Heiko Rosemann"
+EMAIL="heiko.rosemann@web.de"
diff --git a/libraries/aqbanking/slack-desc b/libraries/aqbanking/slack-desc
new file mode 100644
index 0000000000..3ed529e7d2
--- /dev/null
+++ b/libraries/aqbanking/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+aqbanking: AqBanking (library for online banking)
+aqbanking:
+aqbanking: AqBanking offers an interface to generic online banking tasks,
+aqbanking: bank information for the US, Germany, Austria and Switzerland
+aqbanking: and country- and currency-related information.
+aqbanking:
+aqbanking: AqBanking can be used by AqFinance, OrgaMon, GnuCash and KMyMoney
+aqbanking: It supports HBCI (2.01, 2.10, 2.20, FinTS 3.00), EBICS (2.3 and 2.4)
+aqbanking: and OFX Direct Connect.
+aqbanking:
+aqbanking: