summaryrefslogtreecommitdiffstats
path: root/libraries/SFML/SFML.SlackBuild
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-04-20 11:11:51 +0200
committer Willy Sudiarto Raharjo2014-04-23 02:51:51 +0200
commit72fd212d6e23748de03ee608fa27aa3655d4e344 (patch)
tree8c959bcfd7e01bf7f13e67646521a4b853816197 /libraries/SFML/SFML.SlackBuild
parent23d542cf23f6e5517ac4ab4b15b26bed9694f4a9 (diff)
downloadslackbuilds-72fd212d6e23748de03ee608fa27aa3655d4e344.tar.gz
libraries/SFML: Updated for version 2.1 + new maintainer.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/SFML/SFML.SlackBuild')
-rw-r--r--libraries/SFML/SFML.SlackBuild70
1 files changed, 44 insertions, 26 deletions
diff --git a/libraries/SFML/SFML.SlackBuild b/libraries/SFML/SFML.SlackBuild
index d51b99dd93..6a53a2e037 100644
--- a/libraries/SFML/SFML.SlackBuild
+++ b/libraries/SFML/SFML.SlackBuild
@@ -1,12 +1,31 @@
#!/bin/sh
-# Slackware build script for SFML (Simple and Fast Multimedia Library)
+# Slackware build script for SFML
# Written by Pawel Standowicz (standek@gmail.com)
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=SFML
-VERSION=${VERSION:-1.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -22,9 +41,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-# Archive package name suffixes are different depending on system architecture.
-ARCHIVESUFFIX=${ARCHIVESUFFIX:-32} # Default for 32bit systems
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
LIBDIRSUFFIX=""
@@ -34,7 +50,6 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
- ARCHIVESUFFIX="64" # For 64bit systems
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -46,32 +61,35 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION-sdk-linux-$ARCHIVESUFFIX.tar.gz
+unzip $CWD/$PRGNAM-$VERSION-sources.zip
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Patch Makefile so that it respects CFLAGS
-sed -i "s/CFLAGS\ .*=/CFLAGS +=/" src/SFML/Makefile
-
-# Patch Makefile to put libs in correct place
-sed -i "s|(DESTDIR)/lib|(DESTDIR)/lib$LIBDIRSUFFIX|" src/SFML/Makefile
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
-# Add a big patch for gcc-4.7.x
-patch -p1 < $CWD/gcc47.patch
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-CFLAGS="$SLKCFLAGS" \
- make
-make install DESTDIR=$PKG/usr
+rm -rf $PKG/usr/share
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -ar \
- doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a license.txt readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc