summaryrefslogtreecommitdiffstats
path: root/libraries/QuantLib-Python
diff options
context:
space:
mode:
author Aleksandar Samardzic2010-05-12 23:29:49 +0200
committer Robby Workman2010-05-12 23:29:49 +0200
commit5af58a08c6aa1f5bd2cee8e092bce36acf1abec4 (patch)
tree5a5299520f5a7318f8b10443a63757345788a6cd /libraries/QuantLib-Python
parentf564a58fb30a4e6736533406b57472cafb0e1128 (diff)
downloadslackbuilds-5af58a08c6aa1f5bd2cee8e092bce36acf1abec4.tar.gz
libraries/QuantLib-Python: Added to 12.2 repository
Diffstat (limited to 'libraries/QuantLib-Python')
-rw-r--r--libraries/QuantLib-Python/QuantLib-Python.SlackBuild63
-rw-r--r--libraries/QuantLib-Python/QuantLib-Python.info8
-rw-r--r--libraries/QuantLib-Python/README6
-rw-r--r--libraries/QuantLib-Python/slack-desc19
4 files changed, 96 insertions, 0 deletions
diff --git a/libraries/QuantLib-Python/QuantLib-Python.SlackBuild b/libraries/QuantLib-Python/QuantLib-Python.SlackBuild
new file mode 100644
index 0000000000..319c6b3e95
--- /dev/null
+++ b/libraries/QuantLib-Python/QuantLib-Python.SlackBuild
@@ -0,0 +1,63 @@
+#!/bin/sh
+
+# Slackware build script for QuantLib-SWIG
+
+# Written by Aleksandar Samardzic <asamardzic@gmail.com>
+
+PRGNAM=QuantLib-Python
+VERSION=${VERSION:-0.9.7}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=QuantLib-SWIG
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+cd Python
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py install --root $PKG
+
+( cd $PKG
+ find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+ find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ../LICENSE.TXT README.txt examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/libraries/QuantLib-Python/QuantLib-Python.info b/libraries/QuantLib-Python/QuantLib-Python.info
new file mode 100644
index 0000000000..7a277e2174
--- /dev/null
+++ b/libraries/QuantLib-Python/QuantLib-Python.info
@@ -0,0 +1,8 @@
+PRGNAM="QuantLib-Python"
+VERSION="0.9.7"
+HOMEPAGE="http://www.quantlib.org/"
+DOWNLOAD="http://downloads.sourceforge.net/quantlib/QuantLib-SWIG-0.9.7.tar.gz"
+MD5SUM="8f265a9cd71a2978e823c921b4b60eae"
+MAINTAINER="Aleksandar Samardzic"
+EMAIL="asamardzic@gmail.com"
+APPROVED="rworkman"
diff --git a/libraries/QuantLib-Python/README b/libraries/QuantLib-Python/README
new file mode 100644
index 0000000000..860f698545
--- /dev/null
+++ b/libraries/QuantLib-Python/README
@@ -0,0 +1,6 @@
+QuantLib-Python contains Python bindings of the QuantLib, open-source
+C++ library for quantitative finance. The bindings are generated by
+the SWIG tool.
+
+QuantLib-Python requires QuantLib and SWIG, both of which are also
+available from SlackBuilds.org.
diff --git a/libraries/QuantLib-Python/slack-desc b/libraries/QuantLib-Python/slack-desc
new file mode 100644
index 0000000000..5a86e332ad
--- /dev/null
+++ b/libraries/QuantLib-Python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler----------------------------------------------------|
+QuantLib-Python: QuantLib-Python contains QuantLib Python bindings.
+QuantLib-Python:
+QuantLib-Python: QuantLib-Python contains Python bindings of the
+QuantLib-Python: QuantLib, open-source C++ library for quantitative
+QuantLib-Python: finance. The bindings are generated by the SWIG
+QuantLib-Python: tool.
+QuantLib-Python:
+QuantLib-Python: Homepage: http://www.quantlib.org/
+QuantLib-Python:
+QuantLib-Python:
+QuantLib-Python: