summaryrefslogtreecommitdiffstats
path: root/libraries/PySoundCard
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-17 02:00:58 +0100
committer Erik Hanson2014-01-30 06:21:04 +0100
commit2d8d8cf4bb8065693563b33ea8eb1aa18f285392 (patch)
tree0bc42b2b3f143dc7ad9b0673d09f56c76d83dca7 /libraries/PySoundCard
parentf433b234f0c8d5d113a9684fbfaf3971ea179cdc (diff)
downloadslackbuilds-2d8d8cf4bb8065693563b33ea8eb1aa18f285392.tar.gz
libraries/PySoundCard: Added (An audio library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries/PySoundCard')
-rw-r--r--libraries/PySoundCard/PySoundCard.SlackBuild86
-rw-r--r--libraries/PySoundCard/PySoundCard.info10
-rw-r--r--libraries/PySoundCard/README9
-rw-r--r--libraries/PySoundCard/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/libraries/PySoundCard/PySoundCard.SlackBuild b/libraries/PySoundCard/PySoundCard.SlackBuild
new file mode 100644
index 0000000000..d5c2733edd
--- /dev/null
+++ b/libraries/PySoundCard/PySoundCard.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for PySoundCard
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=PySoundCard
+VERSION=${VERSION:-0.4.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/PySoundCard/PySoundCard.info b/libraries/PySoundCard/PySoundCard.info
new file mode 100644
index 0000000000..fd3bbe2bda
--- /dev/null
+++ b/libraries/PySoundCard/PySoundCard.info
@@ -0,0 +1,10 @@
+PRGNAM="PySoundCard"
+VERSION="0.4.3"
+HOMEPAGE="https://github.com/bastibe/PySoundCard"
+DOWNLOAD="https://pypi.python.org/packages/source/P/PySoundCard/PySoundCard-0.4.3.tar.gz"
+MD5SUM="792cd704b884a6186cad76a25ee0c645"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools portaudio numpy cffi"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/PySoundCard/README b/libraries/PySoundCard/README
new file mode 100644
index 0000000000..f87cdade33
--- /dev/null
+++ b/libraries/PySoundCard/README
@@ -0,0 +1,9 @@
+An audio library based on PortAudio, CFFI and NumPy
+
+PySoundCard can play and record audio.
+Audio devices are supported through PortAudio, which is a free,
+cross-platform, open-source audio I/O library that runs on many
+operating systems including Windows, OS X and Linux. It is accessed
+through CFFI, which is a foreign function interface for Python
+calling C code. CFFI is supported for CPython 2.6+, 3.x and PyPy
+2.0+. PySoundCard represents audio data as NumPy arrays.
diff --git a/libraries/PySoundCard/slack-desc b/libraries/PySoundCard/slack-desc
new file mode 100644
index 0000000000..4f8d33cfe3
--- /dev/null
+++ b/libraries/PySoundCard/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+PySoundCard: PySoundCard (An audio library based on PortAudio, CFFI and NumPy)
+PySoundCard:
+PySoundCard: PySoundCard can play and record audio.
+PySoundCard: Audio devices are supported through PortAudio, which is a free,
+PySoundCard: cross-platform, open-source audio I/O library that runs on many
+PySoundCard: operating systems including Windows, OS X and Linux. It is accessed
+PySoundCard: through CFFI, which is a foreign function interface for Python
+PySoundCard: calling C code. CFFI is supported for CPython 2.6+, 3.x and PyPy
+PySoundCard: 2.0+. PySoundCard represents audio data as NumPy arrays.
+PySoundCard:
+PySoundCard: Homepage: https://github.com/bastibe/PySoundCard