summaryrefslogtreecommitdiffstats
path: root/libraries/DirectFB
diff options
context:
space:
mode:
author dsomero2010-05-20 01:51:36 +0200
committer David Somero2010-05-21 06:17:05 +0200
commit37ec84fa0c8ccf42bf5378fdc754b8fa62e80e0e (patch)
treef4d45d440132d76b31cd36aa72c84dd26875ef40 /libraries/DirectFB
parent8355e4dbffbfcb058d665da2f399b01e98e5a5e5 (diff)
downloadslackbuilds-37ec84fa0c8ccf42bf5378fdc754b8fa62e80e0e.tar.gz
libraries/DirectFB: Removed (Won't build due to libpng14)
Diffstat (limited to 'libraries/DirectFB')
-rw-r--r--libraries/DirectFB/DirectFB.SlackBuild97
-rw-r--r--libraries/DirectFB/DirectFB.info10
-rw-r--r--libraries/DirectFB/README7
-rw-r--r--libraries/DirectFB/slack-desc19
4 files changed, 0 insertions, 133 deletions
diff --git a/libraries/DirectFB/DirectFB.SlackBuild b/libraries/DirectFB/DirectFB.SlackBuild
deleted file mode 100644
index c8d7b91eac..0000000000
--- a/libraries/DirectFB/DirectFB.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for DirectFB
-
-# Copyright (c) 2008, Antonio Hernández Blas <hba.nihilismus@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-# 1.- Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
-# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
-# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
-# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
-# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
-# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
-# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=DirectFB
-VERSION=1.0.1
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --enable-shared=yes \
- --enable-static=no \
- --with-gfxdrivers=all \
- --with-inputdrivers=all \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING INSTALL NEWS README TODO \
- docs/README.screenshots docs/html $PKG/usr/doc/$PRGNAM-$VERSION
-rm $PKG/usr/doc/$PRGNAM-$VERSION/html/Makefile*
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/DirectFB/DirectFB.info b/libraries/DirectFB/DirectFB.info
deleted file mode 100644
index a6dc09b73b..0000000000
--- a/libraries/DirectFB/DirectFB.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="DirectFB"
-VERSION="1.0.1"
-HOMEPAGE="http://www.directfb.org"
-DOWNLOAD="http://www.directfb.org/downloads/Core/DirectFB-1.0/DirectFB-1.0.1.tar.gz"
-MD5SUM="539e4b304d08bb0a2080c7b3f321d96f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Antonio Hernández Blas"
-EMAIL="hba.nihilismus@gmail.org"
-APPROVED="dsomero"
diff --git a/libraries/DirectFB/README b/libraries/DirectFB/README
deleted file mode 100644
index c645101c86..0000000000
--- a/libraries/DirectFB/README
+++ /dev/null
@@ -1,7 +0,0 @@
-DirectFB is a thin library that provides developers with hardware
-graphics acceleration, input device handling and abstraction,
-integrated windowing system with support for translucent windows and
-multiple display layers on top of the Linux Framebuffer Device. It is
-a complete hardware abstraction layer with software fallbacks for
-every graphics operation that is not supported by the underlying
-hardware.
diff --git a/libraries/DirectFB/slack-desc b/libraries/DirectFB/slack-desc
deleted file mode 100644
index 4484e7a8fb..0000000000
--- a/libraries/DirectFB/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-DirectFB: DirectFB (A new Linux graphics standard)
-DirectFB:
-DirectFB: DirectFB is a thin library that provides developers with hardware
-DirectFB: graphics acceleration, input device handling and abstraction,
-DirectFB: integrated windowing system with support for translucent windows and
-DirectFB: multiple display layers on top of the Linux Framebuffer Device. It is
-DirectFB: a complete hardware abstraction layer with software fallbacks for
-DirectFB: every graphics operation that is not supported by the underlying
-DirectFB: hardware.
-DirectFB:
-DirectFB: Homepage: http://www.directfb.org