summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author JK Wood2019-12-29 05:05:25 +0100
committer Willy Sudiarto Raharjo2019-12-29 05:05:25 +0100
commitaecb78bda8b6771687267105b156df244aeaa649 (patch)
tree15701fe228f34fd948a03da67c7c1a15bb0b91ae /ham
parentf6de06472d1dd7ca2a2b689c386cf063c64021e6 (diff)
downloadslackbuilds-aecb78bda8b6771687267105b156df244aeaa649.tar.gz
ham/lpsk31: Added (psk31 program for linux).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/lpsk31/Makefile.patch25
-rw-r--r--ham/lpsk31/README9
-rw-r--r--ham/lpsk31/lpsk31.SlackBuild95
-rw-r--r--ham/lpsk31/lpsk31.info10
-rw-r--r--ham/lpsk31/slack-desc19
5 files changed, 158 insertions, 0 deletions
diff --git a/ham/lpsk31/Makefile.patch b/ham/lpsk31/Makefile.patch
new file mode 100644
index 0000000000..79a18a45da
--- /dev/null
+++ b/ham/lpsk31/Makefile.patch
@@ -0,0 +1,25 @@
+--- Makefile.old 2019-12-21 13:44:12.414553374 -0600
++++ Makefile 2019-12-21 14:12:56.166581253 -0600
+@@ -2,8 +2,8 @@
+
+ SHELL = /bin/sh
+ PROJECT = lpsk31
+-BINDIR = /usr/local/bin
+-DOCDIR = /usr/local/share/doc/
++BINDIR = /usr/bin
++DOCDIR = /usr/share/doc/
+ CC = gcc -Wall -march=native -O2 -D_FORTIFY_CODE=2
+
+ objects = cat.o main.o phase.o pskcodec.o screen.o sound.o
+@@ -20,10 +20,7 @@
+ sound.o : sound.h
+
+ install : $(PROJECT)
+- install -m 755 --strip $(PROJECT) $(BINDIR)
+- install -m 644 doc/$(PROJECT).html $(DOCDIR)
+- if test ! -d $(HOME)/$(PROJECT); then mkdir $(HOME)/$(PROJECT); fi
+- install -m 644 default/$(PROJECT)rc $(HOME)/$(PROJECT)
++ install -m 755 --strip $(PROJECT) $(DESTDIR)$(BINDIR)
+
+ uninstall :
+ if test -d $(HOME)/$(PROJECT); then rm -r $(HOME)/$(PROJECT); fi
diff --git a/ham/lpsk31/README b/ham/lpsk31/README
new file mode 100644
index 0000000000..b0884fe689
--- /dev/null
+++ b/ham/lpsk31/README
@@ -0,0 +1,9 @@
+lpsk31 is a ncurses console application for ham radio communications in the
+popular PSK31 digital mode. lpsk31 uses only integer arithmetic for both
+signal detection and audio tone synthesis, so that it needs no floating point
+calculations for its operation. lpsk31 can keep a log of QSO's in text and
+ADIF format as well as a raw log of all that is typed in the transmit window
+or displayed in the receive window. Some QSO data (signal strength and
+frequency) can be acquired automatically via a CAT interface from the
+transceiver itself, if it is an FT847. Unfortunately there is no CAT for other
+types of transceiver since I had problems using Hamlib.
diff --git a/ham/lpsk31/lpsk31.SlackBuild b/ham/lpsk31/lpsk31.SlackBuild
new file mode 100644
index 0000000000..ae33f51350
--- /dev/null
+++ b/ham/lpsk31/lpsk31.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+# Slackbuild for lpsk31
+# Written by JK Wood <joshuakwood@gmail.com>
+
+# Slackbuild is released under the Dog-on-Fire License:
+# If use of this script causes your dog to catch on fire,
+# you agree to send me five dollars. Or a picture
+# of the dog on fire.
+# Otherwise, you're on your own. I've tested the script
+# on my own computer, and it hasn't broken anything.
+# So if it does it on your computer, that falls in
+# the realm of "Not my problem."
+#
+# Of course, if you'll send a bug report to the above
+# email address, I may be able to see what you did
+# wrong and prevent it from happening in the future.
+# In which case, I may just send YOU five dollars.
+
+# Oh, and feel free to copy it and modify it as you
+# see fit. Or as I see fit. Or as I fit. Although
+# that is unlikely, as I am rather tall.
+
+PRGNAM=lpsk31
+VERSION=${VERSION:-1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix home directory screwballery
+patch -p0 < $CWD/Makefile.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make
+
+mkdir -p $PKG/usr/bin
+mkdir -p $PKG/usr/doc
+
+make install DESTDIR=$PKG BINDIR=/usr/bin DOCDIR=/usr/doc
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING README doc/* default/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -name "Makefile" -exec rm {} \;
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/ham/lpsk31/lpsk31.info b/ham/lpsk31/lpsk31.info
new file mode 100644
index 0000000000..ab5870ccbf
--- /dev/null
+++ b/ham/lpsk31/lpsk31.info
@@ -0,0 +1,10 @@
+PRGNAM="lpsk31"
+VERSION="1.3"
+HOMEPAGE="http://www.qsl.net/5b4az/"
+DOWNLOAD="http://www.qsl.net/5b4az/pkg/psk31/lpsk31/lpsk31-1.3.tar.bz2"
+MD5SUM="091ecabd1921c53249e6e85ca45eb2c0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="JK Wood"
+EMAIL="joshuakwood@gmail.com"
diff --git a/ham/lpsk31/slack-desc b/ham/lpsk31/slack-desc
new file mode 100644
index 0000000000..bba9ff0197
--- /dev/null
+++ b/ham/lpsk31/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+lpsk31: lpsk31 (psk31 program for linux)
+lpsk31:
+lpsk31: lpsk31 is a ncurses console application for ham radio communications
+lpsk31: in the popular PSK31 digital mode.
+lpsk31:
+lpsk31: Homepage: https://www.qsl.net/5b4az/
+lpsk31:
+lpsk31:
+lpsk31:
+lpsk31:
+lpsk31: