summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author JK Wood2020-01-16 18:50:20 +0100
committer Willy Sudiarto Raharjo2020-01-16 18:50:26 +0100
commit73b75e9018612846cc1a83817fb5a25d2694da57 (patch)
treef201de4a5889676fc2d1dc3f28858308a2c4bbaa /ham
parent9cb6d7be917885172d9f046277aed16c20333eb1 (diff)
downloadslackbuilds-73b75e9018612846cc1a83817fb5a25d2694da57.tar.gz
ham/direwolf: Updated for version 1.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/direwolf/Makefile.patch149
-rw-r--r--ham/direwolf/direwolf.SlackBuild14
-rw-r--r--ham/direwolf/direwolf.info6
-rw-r--r--ham/direwolf/doinst.sh2
4 files changed, 42 insertions, 129 deletions
diff --git a/ham/direwolf/Makefile.patch b/ham/direwolf/Makefile.patch
index 09f7d75d20..d59530c6b7 100644
--- a/ham/direwolf/Makefile.patch
+++ b/ham/direwolf/Makefile.patch
@@ -1,116 +1,37 @@
---- direwolf-1.1/Makefile.linux 2014-11-21 21:36:04.000000000 -0600
-+++ Makefile.linux 2015-05-14 19:30:26.500837838 -0500
-@@ -4,7 +4,26 @@
-
- all : direwolf decode_aprs text2tt tt2text ll2utm utm2ll aclients log2gpx
-
--CC = gcc
-+CC ?= gcc
-+INSTALL ?= sudo install
-+INSTALL_PROGRAM = $(INSTALL) -m 755
-+INSTALL_DATA = $(INSTALL) -m 644
-+INSTALL_DIR = $(INSTALL) -d
-+
-+prefix ?= /usr/local
-+exec_prefix = $(prefix)
-+bindir ?= $(exec_prefix)/bin
-+docdir ?= $(prefix)/share/doc/direwolf
-+datadir ?= $(prefix)/share/direwolf
-+appdir ?= /usr/share/applications
-+sysconfdir ?= ~
-+LINK_IN_HOME ?= yes
-+
-+ifeq ($(LINK_IN_HOME),yes)
-+ HOME_DESKTOP = ln -f -s /usr/share/applications/direwolf.desktop ~/Desktop/direwolf.desktop
-+else
-+ HOME_DESKTOP =
-+endif
-
+--- Makefile.linux 2020-01-12 19:13:24.593108485 -0600
++++ Makefile.linux 2020-01-12 19:32:32.776127055 -0600
+@@ -665,22 +665,22 @@
#
- # The DSP filters can be sped up considerably with the SSE
-@@ -78,15 +97,17 @@
- # cause compatibility issues for those with older computers.
+ # "man" pages
#
-
--arch := $(shell echo | gcc -E -dM - | grep __i386__)
-+arch ?= $(shell echo | gcc -E -dM - | grep __i386__)
-
--ifneq ($(arch),)
-+ifndef CFLAGS
-+ ifneq ($(arch),)
- # You might see improvement with -march fine tuned to your hardware.
- # Probably should keep pentium3 if you will be redistributing binaries
- # to other people.
--CFLAGS := -O3 -march=pentium3 -pthread -Iutm
--else
--CFLAGS := -O3 -pthread -Iutm
-+ CFLAGS := -O3 -march=pentium3 -pthread -Iutm
-+ else
-+ CFLAGS := -O3 -pthread -Iutm
-+ endif
- endif
-
-
-@@ -150,27 +171,31 @@
- # TODO: Review file locations.
-
- install : direwolf decode_aprs tocalls.txt symbols-new.txt symbolsX.txt dw-icon.png direwolf.desktop
-- install direwolf /usr/local/bin
-- install decode_aprs /usr/local/bin
-- install text2tt /usr/local/bin
-- install tt2text /usr/local/bin
-- install ll2utm /usr/local/bin
-- install utm2ll /usr/local/bin
-- install aclients /usr/local/bin
-- install log2gpx /usr/local/bin
-- install -D --mode=644 tocalls.txt /usr/share/direwolf/tocalls.txt
-- install -D --mode=644 symbols-new.txt /usr/share/direwolf/symbols-new.txt
-- install -D --mode=644 symbolsX.txt /usr/share/direwolf/symbolsX.txt
-- install -D --mode=644 dw-icon.png /usr/share/direwolf/dw-icon.png
-- install -D --mode=644 direwolf.desktop /usr/share/applications/direwolf.desktop
-- install -D --mode=644 CHANGES.txt /usr/local/share/doc/direwolf/CHANGES.txt
-- install -D --mode=644 LICENSE-dire-wolf.txt /usr/local/share/doc/direwolf/LICENSE-dire-wolf.txt
-- install -D --mode=644 LICENSE-other.txt /usr/local/share/doc/direwolf/LICENSE-other.txt
-- install -D --mode=644 User-Guide.pdf /usr/local/share/doc/direwolf/User-Guide.pdf
-- install -D --mode=644 Raspberry-Pi-APRS.pdf /usr/local/share/doc/direwolf/Raspberry-Pi-APRS.pdf
-- install -D --mode=644 Raspberry-Pi-APRS-Tracker.pdf /usr/local/share/doc/direwolf/Raspberry-Pi-APRS-Tracker.pdf
-- install -D --mode=644 APRStt-Implementation-Notes.pdf /usr/local/share/doc/direwolf/APRStt-Implementation-Notes.pdf
-- install -D --mode=644 Quick-Start-Guide-Windows.pdf /usr/local/share/doc/direwolf/Quick-Start-Guide-Windows.pdf
-+ $(INSTALL_DIR) $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) direwolf $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) decode_aprs $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) text2tt $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) tt2text $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) ll2utm $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) utm2ll $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) aclients $(DESTDIR)$(bindir)/
-+ $(INSTALL_PROGRAM) log2gpx $(DESTDIR)$(bindir)/
-+ $(INSTALL_DIR) $(DESTDIR)$(datadir)
-+ $(INSTALL_DATA) tocalls.txt $(DESTDIR)$(datadir)/
-+ $(INSTALL_DATA) symbols-new.txt $(DESTDIR)$(datadir)/
-+ $(INSTALL_DATA) symbolsX.txt $(DESTDIR)$(datadir)/
-+ $(INSTALL_DATA) dw-icon.png $(DESTDIR)$(datadir)/
-+ $(INSTALL_DIR) $(DESTDIR)$(appdir)
-+ $(INSTALL_DATA) direwolf.desktop $(DESTDIR)$(appdir)/
-+ $(INSTALL_DIR) $(DESTDIR)$(docdir)
-+ $(INSTALL_DATA) CHANGES.txt $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) LICENSE-dire-wolf.txt $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) LICENSE-other.txt $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) User-Guide.pdf $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) Raspberry-Pi-APRS.pdf $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) Raspberry-Pi-APRS-Tracker.pdf $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) APRStt-Implementation-Notes.pdf $(DESTDIR)$(docdir)/
-+ $(INSTALL_DATA) Quick-Start-Guide-Windows.pdf $(DESTDIR)$(docdir)/
-
-
- # The Raspberry Pi has ~/Desktop but Ubuntu does not.
-@@ -183,7 +208,8 @@
- ln -f -s /usr/share/applications/direwolf.desktop ~/Desktop/direwolf.desktop
-
- install-conf : direwolf.conf
-- cp direwolf.conf ~
-+ $(INSTALL_DIR) $(DESTDIR)$(sysconfdir)
-+ $(INSTALL_DATA) direwolf.conf $(DESTDIR)$(sysconfdir)/
-
-
- # Separate application to decode raw data.
+- $(INSTALL) -D --mode=644 man1/aclients.1 $(DESTDIR)/share/man/man1/aclients.1
+- $(INSTALL) -D --mode=644 man1/atest.1 $(DESTDIR)/share/man/man1/atest.1
+- $(INSTALL) -D --mode=644 man1/decode_aprs.1 $(DESTDIR)/share/man/man1/decode_aprs.1
+- $(INSTALL) -D --mode=644 man1/direwolf.1 $(DESTDIR)/share/man/man1/direwolf.1
+- $(INSTALL) -D --mode=644 man1/gen_packets.1 $(DESTDIR)/share/man/man1/gen_packets.1
+- $(INSTALL) -D --mode=644 man1/kissutil.1 $(DESTDIR)/share/man/man1/kissutil.1
+- $(INSTALL) -D --mode=644 man1/ll2utm.1 $(DESTDIR)/share/man/man1/ll2utm.1
+- $(INSTALL) -D --mode=644 man1/log2gpx.1 $(DESTDIR)/share/man/man1/log2gpx.1
+- $(INSTALL) -D --mode=644 man1/text2tt.1 $(DESTDIR)/share/man/man1/text2tt.1
+- $(INSTALL) -D --mode=644 man1/tt2text.1 $(DESTDIR)/share/man/man1/tt2text.1
+- $(INSTALL) -D --mode=644 man1/utm2ll.1 $(DESTDIR)/share/man/man1/utm2ll.1
++ $(INSTALL) -D --mode=644 man1/aclients.1 $(DESTDIR)/man/man1/aclients.1
++ $(INSTALL) -D --mode=644 man1/atest.1 $(DESTDIR)/man/man1/atest.1
++ $(INSTALL) -D --mode=644 man1/decode_aprs.1 $(DESTDIR)/man/man1/decode_aprs.1
++ $(INSTALL) -D --mode=644 man1/direwolf.1 $(DESTDIR)/man/man1/direwolf.1
++ $(INSTALL) -D --mode=644 man1/gen_packets.1 $(DESTDIR)/man/man1/gen_packets.1
++ $(INSTALL) -D --mode=644 man1/kissutil.1 $(DESTDIR)/man/man1/kissutil.1
++ $(INSTALL) -D --mode=644 man1/ll2utm.1 $(DESTDIR)/man/man1/ll2utm.1
++ $(INSTALL) -D --mode=644 man1/log2gpx.1 $(DESTDIR)/man/man1/log2gpx.1
++ $(INSTALL) -D --mode=644 man1/text2tt.1 $(DESTDIR)/man/man1/text2tt.1
++ $(INSTALL) -D --mode=644 man1/tt2text.1 $(DESTDIR)/man/man1/tt2text.1
++ $(INSTALL) -D --mode=644 man1/utm2ll.1 $(DESTDIR)/man/man1/utm2ll.1
+ #
+ # Set group and mode of HID devices corresponding to C-Media USB Audio adapters.
+ # This will allow us to use the CM108/CM119 GPIO pins for PTT.
+ #
+- $(INSTALL) -D --mode=644 99-direwolf-cmedia.rules /etc/udev/rules.d/99-direwolf-cmedia.rules
++ $(INSTALL) -D --mode=644 99-direwolf-cmedia.rules $(DESTDIR)/lib/udev/rules.d/99-direwolf-cmedia.rules
+ #
+ @echo " "
+ @echo "If this is your first install, not an upgrade, type this to put a copy"
diff --git a/ham/direwolf/direwolf.SlackBuild b/ham/direwolf/direwolf.SlackBuild
index 83226d1803..e9f0bbe1ae 100644
--- a/ham/direwolf/direwolf.SlackBuild
+++ b/ham/direwolf/direwolf.SlackBuild
@@ -21,7 +21,7 @@
# that is unlikely, as I am rather tall.
PRGNAM=direwolf
-VERSION=${VERSION:-1.1}
+VERSION=${VERSION:-1.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -68,7 +68,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix some silly Makefile choices
-todos < $CWD/Makefile.patch | patch -p0 --binary
+patch -p0 < $CWD/Makefile.patch
CFLAGS="$SLKCFLAGS -DUSE_ALSA -pthread -Iutm" \
LDFLAGS="-L/lib${LIBDIRSUFFIX} -L/usr/lib${LIBDIRSUFFIX}" \
@@ -78,16 +78,10 @@ INSTALL=install \
docdir=/usr/doc/$PRGNAM-$VERSION \
sysconfdir=/etc \
LINK_IN_HOME=no \
-make -f Makefile.linux install install-conf DESTDIR=$PKG
+make -f Makefile.linux install DESTDIR=$PKG/usr
-# direwolf comes with a lovely desktop
-# file that assumes LXDE. Use our own
-# here.
-install -m 644 $CWD/direwolf.desktop $PKG/usr/share/applications/
mkdir -p $PKG/usr/share/pixmaps
-cp -a $PKG/usr/share/direwolf/dw-icon.png $PKG/usr/share/pixmaps/
-
-mv $PKG/etc/direwolf.conf $PKG/etc/direwolf.conf.new
+cp -a $PKG/usr/share/direwolf/pixmaps/dw-icon.png $PKG/usr/share/pixmaps/
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/ham/direwolf/direwolf.info b/ham/direwolf/direwolf.info
index 150506953b..532b543811 100644
--- a/ham/direwolf/direwolf.info
+++ b/ham/direwolf/direwolf.info
@@ -1,8 +1,8 @@
PRGNAM="direwolf"
-VERSION="1.1"
+VERSION="1.5"
HOMEPAGE="https://github.com/wb2osz/direwolf"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/direwolf-1.1-src.zip"
-MD5SUM="6ea127d4c952eec1e5fb07355045f41d"
+DOWNLOAD="https://github.com/wb2osz/direwolf/archive/1.5/direwolf-1.5-src.zip"
+MD5SUM="14572b9179a171e33c1e6f28ef5e8333"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/ham/direwolf/doinst.sh b/ham/direwolf/doinst.sh
index 63af7cb856..473ca0981c 100644
--- a/ham/direwolf/doinst.sh
+++ b/ham/direwolf/doinst.sh
@@ -11,8 +11,6 @@ config() {
# Otherwise, we leave the .new copy for the admin to consider...
}
-config etc/direwolf.conf.new
-
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi