summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author Alan Aversa2017-08-24 14:47:47 +0200
committer Willy Sudiarto Raharjo2017-08-26 02:19:46 +0200
commit1e7e27a52b846c54d686c927877a631403d87c92 (patch)
tree09bde51f44f6d9db9cd9ac33c7354e4732d33060 /ham
parentf998d98cd7a200ca29bd176bc784e71bab282221 (diff)
downloadslackbuilds-1e7e27a52b846c54d686c927877a631403d87c92.tar.gz
ham/SoapySDR: Added (SDR support library).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/SoapySDR/README10
-rw-r--r--ham/SoapySDR/SoapySDR.SlackBuild103
-rw-r--r--ham/SoapySDR/SoapySDR.info10
-rw-r--r--ham/SoapySDR/slack-desc19
4 files changed, 142 insertions, 0 deletions
diff --git a/ham/SoapySDR/README b/ham/SoapySDR/README
new file mode 100644
index 0000000000..6d0bfaaa83
--- /dev/null
+++ b/ham/SoapySDR/README
@@ -0,0 +1,10 @@
+Features
+
+SoapySDR is an open-source generalized C/C++ API and runtime library
+for interfacing with SDR devices. With SoapySDR, you can instantiate,
+configure, and stream with an SDR device in a variety of environments.
+Both osmosdr and uhd devices are available within SoapySDR. In
+addition, vendors can directly support their hardware using SoapySDR
+device modules. There are wrappers for both gr-osmosdr, uhd, and gr-uhd
+to bring an ecosystem of existing applications to SoapySDR devices. And
+SoapySDR has support for powerful platforms like GNU Radio and Pothos.
diff --git a/ham/SoapySDR/SoapySDR.SlackBuild b/ham/SoapySDR/SoapySDR.SlackBuild
new file mode 100644
index 0000000000..113c2294a5
--- /dev/null
+++ b/ham/SoapySDR/SoapySDR.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/sh
+
+# Slackware build script for SoapySDR
+
+# Copyright 2017 Alan Aversa USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=SoapySDR
+VERSION=${VERSION:-0.6.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=SoapySDR-soapy-sdr
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i -e 's#share/man#man#' apps/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DENABLE_PYTHON3:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE_1_0.txt Changelog.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/ham/SoapySDR/SoapySDR.info b/ham/SoapySDR/SoapySDR.info
new file mode 100644
index 0000000000..eafd41bb12
--- /dev/null
+++ b/ham/SoapySDR/SoapySDR.info
@@ -0,0 +1,10 @@
+PRGNAM="SoapySDR"
+VERSION="0.6.0"
+HOMEPAGE="https://github.com/pothosware/SoapySDR"
+DOWNLOAD="https://github.com/pothosware/SoapySDR/archive/soapy-sdr-0.6.0/SoapySDR-soapy-sdr-0.6.0.tar.gz"
+MD5SUM="f662b12c8a5ac7770c35a6a597ef31fc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Alan Aversa"
+EMAIL="alan.aveNOrsaSP@AMcox.net (remove NO and SPAM)"
diff --git a/ham/SoapySDR/slack-desc b/ham/SoapySDR/slack-desc
new file mode 100644
index 0000000000..69437e8de2
--- /dev/null
+++ b/ham/SoapySDR/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+SoapySDR: SoapySDR (vendor and platform neutral SDR support library)
+SoapySDR:
+SoapySDR: SoapySDR is an open-source generalized C/C++ API and runtime library
+SoapySDR: for interfacing with SDR devices. With SoapySDR, you can instantiate,
+SoapySDR: configure, and stream with an SDR device in a variety of
+SoapySDR: environments. Both osmosdr and uhd devices are available within
+SoapySDR: SoapySDR. In addition, vendors can directly support their hardware
+SoapySDR: using SoapySDR device modules. There are wrappers for both gr-osmosdr,
+SoapySDR: uhd, and gr-uhd to bring an ecosystem of existing applications to
+SoapySDR: SoapySDR devices. And SoapySDR has support for powerful platforms like
+SoapySDR: GNU Radio and Pothos.