summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author JK Wood2014-07-16 14:00:22 +0200
committer Willy Sudiarto Raharjo2014-07-16 14:00:22 +0200
commit26135b1acc16cb252a1211b1b1571a297e11f69d (patch)
treeb2c8b206b6a9f7e4464113b371524e63a6f27ba3 /ham
parent142eab5bf688cc074c11585c0415db684367d05b (diff)
downloadslackbuilds-26135b1acc16cb252a1211b1b1571a297e11f69d.tar.gz
ham/xfhell: Added (GTK+ Hellschreiber program for Linux).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/xfhell/Makefile.patch16
-rw-r--r--ham/xfhell/README22
-rw-r--r--ham/xfhell/slack-desc19
-rw-r--r--ham/xfhell/xfhell.SlackBuild102
-rw-r--r--ham/xfhell/xfhell.info10
5 files changed, 169 insertions, 0 deletions
diff --git a/ham/xfhell/Makefile.patch b/ham/xfhell/Makefile.patch
new file mode 100644
index 0000000000..b3e9280fdc
--- /dev/null
+++ b/ham/xfhell/Makefile.patch
@@ -0,0 +1,16 @@
+--- Makefile.in 2013-11-22 23:52:08.000000000 -0600
++++ Makefile.in.fixed 2014-07-13 16:12:24.469504204 -0500
+@@ -820,13 +820,6 @@
+ done \
+ fi
+
+- if test -d $(HOME)/$(PACKAGE); then \
+- echo Working directory exists: $(HOME)/$(PACKAGE) - not copying; \
+- else \
+- echo Copying $(PACKAGE) working directory to $(HOME)/$(PACKAGE); \
+- cp -r $(srcdir)/$(PACKAGE) $(HOME); \
+- fi
+-
+ dist-hook:
+ if test -d pixmaps; then \
+ mkdir $(distdir)/pixmaps; \
diff --git a/ham/xfhell/README b/ham/xfhell/README
new file mode 100644
index 0000000000..e1edd82c61
--- /dev/null
+++ b/ham/xfhell/README
@@ -0,0 +1,22 @@
+xfhell is a GTK+ application for the "fuzzy" digital communication mode
+known as Hellschreiber. xfhell has several different built-in fonts in
+Adobe BDF format, including a font set for Greek, and a special "short"
+font set that is 12 pixels high instead of the standard 14 of the original
+Hell fonts. Using this font set would make xfhell incompatible with other
+Hellschreiber programs, but the short fonts speed up operation and avoid
+wasted bandwidth, inherent in the original Hellschreiber design (an
+unavoidable problem of the original mechanical implementation of the mode).
+xfhell also has selectable lower baud rate operation (down to 7.6 Bd),
+which again make it incompatible with other Hellschreiber programs, but
+the lower speeds (especially combined with the 12-pixel fonts) would make
+this mode even more efficient and effective.
+
+xfhell has built-in CAT control for the FT847 and FT857 transceivers and a
+QSO logging facility similar to xpsk31. It also has a FFT-derived waterfall
+display of the incoming signal, with the ability to detect maximum signal
+level and tune the transceiver, via CAT, to the appropriate carrier
+frequency by clicking near the signal trace.
+
+By default, xfhell wants to install a directory structure in the $HOME of
+the installing user. The SlackBuild overrides this, and copies that structure
+into /usr/share/xfhell-$VERSION/.
diff --git a/ham/xfhell/slack-desc b/ham/xfhell/slack-desc
new file mode 100644
index 0000000000..94fe9e70b2
--- /dev/null
+++ b/ham/xfhell/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xfhell: xfhell (GTK+ Hellschreiber program for Linux)
+xfhell:
+xfhell: xfhell is a GTK+ application for the "fuzzy" digital communication
+xfhell: mode known as Hellschreiber.
+xfhell:
+xfhell:
+xfhell:
+xfhell:
+xfhell:
+xfhell: Homepage: http://www.qsl.net/5b4az/
+xfhell:
diff --git a/ham/xfhell/xfhell.SlackBuild b/ham/xfhell/xfhell.SlackBuild
new file mode 100644
index 0000000000..85f8d324d9
--- /dev/null
+++ b/ham/xfhell/xfhell.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+# Slackbuild for xfhell
+# Written by JK Wood <joshuakwood@gmail.com>
+
+# Slackbuild is released under the Dog-on-Fire License:
+# If use of this script causes your dog to catch on fire,
+# you agree to send me five dollars. Or a picture
+# of the dog on fire.
+# Otherwise, you're on your own. I've tested the script
+# on my own computer, and it hasn't broken anything.
+# So if it does it on your computer, that falls in
+# the realm of "Not my problem."
+#
+# Of course, if you'll send a bug report to the above
+# email address, I may be able to see what you did
+# wrong and prevent it from happening in the future.
+# In which case, I may just send YOU five dollars.
+
+# Oh, and feel free to copy it and modify it as you
+# see fit. Or as I see fit. Or as I fit. Although
+# that is unlikely, as I am rather tall.
+
+PRGNAM=xfhell
+VERSION=${VERSION:-2.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix up home directory screwballery
+patch -p0 < $CWD/Makefile.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --mandir=/usr/man \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -a xfhell $PKG/usr/share/$PRGNAM-$VERSION
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -name "Makefile" -exec rm {} \;
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG${PKGTYPE:-.tgz}
diff --git a/ham/xfhell/xfhell.info b/ham/xfhell/xfhell.info
new file mode 100644
index 0000000000..7b70c48e91
--- /dev/null
+++ b/ham/xfhell/xfhell.info
@@ -0,0 +1,10 @@
+PRGNAM="xfhell"
+VERSION="2.6"
+HOMEPAGE="http://www.qsl.net/5b4az/"
+DOWNLOAD="http://www.qsl.net/5b4az/pkg/xfhell/xfhell-2.6.tar.bz2"
+MD5SUM="0496def817af99b0a890a5dddf69c988"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="JK Wood"
+EMAIL="joshuakwood@gmail.com"