summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author JK Wood2014-07-16 13:56:43 +0200
committer Willy Sudiarto Raharjo2014-07-16 13:56:43 +0200
commit142eab5bf688cc074c11585c0415db684367d05b (patch)
treeb6799a9652e322a4f11da6c7ec5bf8b4dbf9c870 /ham
parentd13e718fb014ad4cdf658667755bb34eaf814458 (diff)
downloadslackbuilds-142eab5bf688cc074c11585c0415db684367d05b.tar.gz
ham/xpsk31: Added (GTK+ PSK31 program).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/xpsk31/Makefile.patch16
-rw-r--r--ham/xpsk31/README13
-rw-r--r--ham/xpsk31/slack-desc19
-rw-r--r--ham/xpsk31/xpsk31.SlackBuild102
-rw-r--r--ham/xpsk31/xpsk31.info10
5 files changed, 160 insertions, 0 deletions
diff --git a/ham/xpsk31/Makefile.patch b/ham/xpsk31/Makefile.patch
new file mode 100644
index 0000000000..c18c549087
--- /dev/null
+++ b/ham/xpsk31/Makefile.patch
@@ -0,0 +1,16 @@
+--- Makefile.in 2013-10-08 07:24:49.000000000 -0500
++++ Makefile.in.fixed 2014-07-13 15:49:21.000135581 -0500
+@@ -821,13 +821,6 @@
+ done \
+ fi
+
+- if test -d $(HOME)/$(PACKAGE); then \
+- echo Working directory exists: $(HOME)/$(PACKAGE) - not copying; \
+- else \
+- echo Copying $(PACKAGE) working directory to $(HOME)/$(PACKAGE); \
+- cp -r $(srcdir)/$(PACKAGE) $(HOME); \
+- fi
+-
+ dist-hook:
+ if test -d pixmaps; then \
+ mkdir $(distdir)/pixmaps; \
diff --git a/ham/xpsk31/README b/ham/xpsk31/README
new file mode 100644
index 0000000000..1ffc807e2d
--- /dev/null
+++ b/ham/xpsk31/README
@@ -0,0 +1,13 @@
+xpsk31 is a GTK+ graphical version of lpsk31, using the same basic
+signal decoding and encoding engine but controlled by the user via
+the GUI. In addition it has a FFT-derived "waterfall" display of
+the incoming signal and a "magniphase" display that shows the magnitude,
+phase and frequency error of the psk31 signal. It has similar QSO
+logging facilities and CAT control, for the FT847 and FT857 transceivers,
+which can be used to tune the transceiver to the appropriate carrier
+frequency by clicking on a signal trace.
+
+By default, xpsk31 wants to install a config file into the installing
+user's home directory. This has been redirected to
+/usr/share/xpsk31-$VERSION/xpsx31rc and can be installed
+from there into ~/xpsk31/.
diff --git a/ham/xpsk31/slack-desc b/ham/xpsk31/slack-desc
new file mode 100644
index 0000000000..0bcd1e586f
--- /dev/null
+++ b/ham/xpsk31/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xpsk31: xpsk31 (GTK+ PSK31 program)
+xpsk31:
+xpsk31: xpsk31 is a GTK+ graphical version of lpsk31, using the same basic
+xpsk31: signal decoding and encoding engine but controlled by the user via the
+xpsk31: GUI.
+xpsk31:
+xpsk31:
+xpsk31:
+xpsk31:
+xpsk31: Homepage: http://www.qsl.net/5b4az/
+xpsk31:
diff --git a/ham/xpsk31/xpsk31.SlackBuild b/ham/xpsk31/xpsk31.SlackBuild
new file mode 100644
index 0000000000..7d9eca9556
--- /dev/null
+++ b/ham/xpsk31/xpsk31.SlackBuild
@@ -0,0 +1,102 @@
+#!/bin/sh
+# Slackbuild for xpsk31
+# Written by JK Wood <joshuakwood@gmail.com>
+
+# Slackbuild is released under the Dog-on-Fire License:
+# If use of this script causes your dog to catch on fire,
+# you agree to send me five dollars. Or a picture
+# of the dog on fire.
+# Otherwise, you're on your own. I've tested the script
+# on my own computer, and it hasn't broken anything.
+# So if it does it on your computer, that falls in
+# the realm of "Not my problem."
+#
+# Of course, if you'll send a bug report to the above
+# email address, I may be able to see what you did
+# wrong and prevent it from happening in the future.
+# In which case, I may just send YOU five dollars.
+
+# Oh, and feel free to copy it and modify it as you
+# see fit. Or as I see fit. Or as I fit. Although
+# that is unlikely, as I am rather tall.
+
+PRGNAM=xpsk31
+VERSION=${VERSION:-2.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix home directory screwballery
+patch -p0 < $CWD/Makefile.patch
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --mandir=/usr/man \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+install -m 644 xpsk31/xpsk31rc $PKG/usr/share/$PRGNAM-$VERSION
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README doc/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -name "Makefile" -exec rm {} \;
+find $PKG/usr/doc -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG${PKGTYPE:-.tgz}
diff --git a/ham/xpsk31/xpsk31.info b/ham/xpsk31/xpsk31.info
new file mode 100644
index 0000000000..cad248dbae
--- /dev/null
+++ b/ham/xpsk31/xpsk31.info
@@ -0,0 +1,10 @@
+PRGNAM="xpsk31"
+VERSION="2.7"
+HOMEPAGE="http://www.qsl.net/5b4az/"
+DOWNLOAD="http://www.qsl.net/5b4az/pkg/psk31/xpsk31/xpsk31-2.7.tar.bz2"
+MD5SUM="44be9759a5dbba60bd0e91249f1e1182"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="JK Wood"
+EMAIL="joshuakwood@gmail.com"