summaryrefslogtreecommitdiffstats
path: root/ham
diff options
context:
space:
mode:
author Robby Workman2014-05-19 03:29:50 +0200
committer Willy Sudiarto Raharjo2014-05-19 06:01:36 +0200
commitd1ea67b1485b1eea4c6a247b4410ca614cdb91e6 (patch)
tree3a2f12cbbb727d566df6b816de1da32d699466eb /ham
parenta4bc9b209654a6818d05a554c50ef76037050131 (diff)
downloadslackbuilds-d1ea67b1485b1eea4c6a247b4410ca614cdb91e6.tar.gz
ham/chirp: Added (amateur radio programming tool).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham')
-rw-r--r--ham/chirp/README3
-rw-r--r--ham/chirp/chirp.SlackBuild92
-rw-r--r--ham/chirp/chirp.info10
-rw-r--r--ham/chirp/doinst.sh3
-rw-r--r--ham/chirp/fixup-chirp.desktop.patch21
-rw-r--r--ham/chirp/slack-desc19
6 files changed, 148 insertions, 0 deletions
diff --git a/ham/chirp/README b/ham/chirp/README
new file mode 100644
index 0000000000..4d76f85956
--- /dev/null
+++ b/ham/chirp/README
@@ -0,0 +1,3 @@
+CHIRP is a free, open-source tool for programming your amateur radio.
+It supports a large number of manufacturers and models, as well as
+provides a way to interface with multiple data sources and formats.
diff --git a/ham/chirp/chirp.SlackBuild b/ham/chirp/chirp.SlackBuild
new file mode 100644
index 0000000000..56f72d8718
--- /dev/null
+++ b/ham/chirp/chirp.SlackBuild
@@ -0,0 +1,92 @@
+#!/bin/sh
+
+# Slackware build script for chirp
+
+# Copyright 2014 Robby Workman, Northport, Alabama, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=chirp
+VERSION=${VERSION:-0.4.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Make the desktop file validate and be otherwise useful...
+patch -p1 < $CWD/fixup-chirp.desktop.patch
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
+ grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/share/doc
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/ham/chirp/chirp.info b/ham/chirp/chirp.info
new file mode 100644
index 0000000000..ec9d456544
--- /dev/null
+++ b/ham/chirp/chirp.info
@@ -0,0 +1,10 @@
+PRGNAM="chirp"
+VERSION="0.4.0"
+HOMEPAGE="http://chirp.danplanet.com/projects/chirp/wiki/Home"
+DOWNLOAD="http://chirp.danplanet.com/download/0.4.0/chirp-0.4.0.tar.gz"
+MD5SUM="1019e25c35ca140c56099538b98258c7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyserial"
+MAINTAINER="Robby Workman"
+EMAIL="rworkman@slackbuilds.org"
diff --git a/ham/chirp/doinst.sh b/ham/chirp/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/ham/chirp/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/ham/chirp/fixup-chirp.desktop.patch b/ham/chirp/fixup-chirp.desktop.patch
new file mode 100644
index 0000000000..7f7ee5eae8
--- /dev/null
+++ b/ham/chirp/fixup-chirp.desktop.patch
@@ -0,0 +1,21 @@
+diff -Nur chirp-0.4.0.orig/share/chirp.desktop chirp-0.4.0/share/chirp.desktop
+--- chirp-0.4.0.orig/share/chirp.desktop 2012-02-15 13:46:54.000000000 -0600
++++ chirp-0.4.0/share/chirp.desktop 2014-05-18 22:39:37.171092107 -0500
+@@ -1,13 +1,11 @@
+ [Desktop Entry]
+-Version=0.1
+-Encoding=UTF-8
++Version=1.0
+ Type=Application
+ Exec=chirpw
+-Icon=chirp.png
++Icon=chirp
+ StartupNotify=true
+ Terminal=false
+-Categories=Application;HamRadio
+-MimeType=inode/directory
++Categories=Development;HamRadio;
++MimeType=inode/directory;
+ Name=CHIRP
+ Comment=CHIRP Radio Programming Tool
+-GenericName=CHIRP Radio Programming Tool
diff --git a/ham/chirp/slack-desc b/ham/chirp/slack-desc
new file mode 100644
index 0000000000..7d3fcf7b0b
--- /dev/null
+++ b/ham/chirp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+chirp: chirp (free, open-source tool for programming your amateur radio)
+chirp:
+chirp: CHIRP is a free, open-source tool for programming your amateur radio.
+chirp: It supports a large number of manufacturers and models, as well as
+chirp: provides a way to interface with multiple data sources and formats.
+chirp:
+chirp: Homepage: http://chirp.danplanet.com/projects/chirp/wiki/Home
+chirp:
+chirp:
+chirp:
+chirp: