summaryrefslogtreecommitdiffstats
path: root/ham/gridloc/Makefile.patch
diff options
context:
space:
mode:
author JK Wood2014-07-14 02:43:28 +0200
committer Willy Sudiarto Raharjo2014-07-16 13:26:48 +0200
commitf507c627d62ab173264d514c6070b9480a11fe9d (patch)
tree1f3e61b89ef46c4059b8c26a8507b314a1359062 /ham/gridloc/Makefile.patch
parent1538120989d22c36b57d6521daf531df9b80d695 (diff)
downloadslackbuilds-f507c627d62ab173264d514c6070b9480a11fe9d.tar.gz
ham/gridloc: Added (Maidenhead grid locator).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'ham/gridloc/Makefile.patch')
-rw-r--r--ham/gridloc/Makefile.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/ham/gridloc/Makefile.patch b/ham/gridloc/Makefile.patch
new file mode 100644
index 0000000000..3c73ff51c7
--- /dev/null
+++ b/ham/gridloc/Makefile.patch
@@ -0,0 +1,38 @@
+--- Makefile 2013-01-12 09:35:12.000000000 -0600
++++ Makefile.fixed 2014-07-12 22:27:44.617601703 -0500
+@@ -1,9 +1,10 @@
+ #Makefile for gridloc
+
++DESTDIR ?= /usr
+ SHELL = /bin/sh
+ PROJECT = gridloc
+-BINDIR = /usr/local/bin
+-DOCDIR = /usr/local/share/doc/
++BINDIR = /usr/bin/
++DOCDIR = /usr/doc/$(PROJECT)-0.7/
+ CC = gcc -Wall -O2 -march=native -D_FORTIFY_SOURCE=2
+
+ objects = calculate.o gridloc.o shared.o screen.o
+@@ -14,14 +15,16 @@
+ $(objects) : $(PROJECT).h
+
+ install : $(PROJECT)
+- install -m 755 --strip $(PROJECT) $(BINDIR)
+- install -m 644 doc/$(PROJECT).html $(DOCDIR)
+- install -m 644 default/.$(PROJECT)rc $(HOME)
++ install -d -v $(DESTDIR)$(BINDIR)
++ install -d -v $(DESTDIR)$(DOCDIR)
++ install -m 755 --strip $(PROJECT) $(DESTDIR)$(BINDIR)
++ install -m 644 doc/$(PROJECT).html $(DESTDIR)$(DOCDIR)
++ install -m 644 default/.$(PROJECT)rc $(DESTDIR)$(DOCDIR)
+
+ uninstall :
+- rm $(BINDIR)/$(PROJECT)
+- rm $(DOCDIR)/$(PROJECT).html
+- rm $(HOME)/.$(PROJECT)rc
++ rm $(DESTDIR)$(BINDIR)$(PROJECT)
++ rm $(DESTDIR)$(DOCDIR)/$(PROJECT).html
++ rm $(DESTDIR)$(DOCDIR)/.$(PROJECT)rc
+
+ clean :
+ rm -f *.o *~