summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Steven Voges2022-08-18 08:54:32 +0200
committer Willy Sudiarto Raharjo2022-08-20 05:06:40 +0200
commit18ce2e1a430132541690f6fbf9eae0941face1a2 (patch)
treec506c64a71f00b9b18f4351d4baec179103a3705 /graphics
parent4828180411cb673d1720fc113c43f872d3c14c27 (diff)
downloadslackbuilds-18ce2e1a430132541690f6fbf9eae0941face1a2.tar.gz
graphics/mangohud: Updated for version 0.6.8.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/mangohud/README2
-rw-r--r--graphics/mangohud/doinst.sh5
-rw-r--r--graphics/mangohud/mangohud.SlackBuild13
-rw-r--r--graphics/mangohud/mangohud.info14
-rw-r--r--graphics/mangohud/meson594.patch11
-rw-r--r--graphics/mangohud/slack-desc2
6 files changed, 32 insertions, 15 deletions
diff --git a/graphics/mangohud/README b/graphics/mangohud/README
index e9caaf0449..86a13f46e6 100644
--- a/graphics/mangohud/README
+++ b/graphics/mangohud/README
@@ -14,7 +14,7 @@ the build script.
This SlackBuild defaults to building mangoapp as well. To
disable this behavior, pass MANGOAPP=false to the build
script. This removes the dependency on glfw3 and
-nlohmann_json's include.zip
+nlohmann_json.
If you would like multilib support, pass COMPAT32=yes to
the build script. Please note that this only adds 32bit
diff --git a/graphics/mangohud/doinst.sh b/graphics/mangohud/doinst.sh
new file mode 100644
index 0000000000..4110f5514d
--- /dev/null
+++ b/graphics/mangohud/doinst.sh
@@ -0,0 +1,5 @@
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/graphics/mangohud/mangohud.SlackBuild b/graphics/mangohud/mangohud.SlackBuild
index f087509562..72796e07bb 100644
--- a/graphics/mangohud/mangohud.SlackBuild
+++ b/graphics/mangohud/mangohud.SlackBuild
@@ -26,8 +26,8 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=mangohud
SRCNAM=MangoHud
-VERSION=${VERSION:-0.6.7.1}
-SRCVER=${SRCVER:-0.6.7-1}
+VERSION=${VERSION:-0.6.8}
+SRCVER=${SRCVER:-0.6.8}
IMGUIVER=${IMGUIVER:-1.81}
SPDLOGVER=${SPDLOGVER:-1.8.5}
BUILD=${BUILD:-1}
@@ -82,18 +82,19 @@ tar xvf $CWD/imgui-$IMGUIVER.tar.gz
unzip $CWD/imgui_$IMGUIVER-1_patch.zip
tar xvf $CWD/spdlog-$SPDLOGVER.tar.gz
unzip $CWD/spdlog_$SPDLOGVER-1_patch.zip
-if [ "$MANGOAPP" = "true" ]; then
- unzip $CWD/include.zip -d nlohmann_json-3.10.5
-fi
cd ..
chown -R root:root .
+#Slackware 15.0 ships meson 59.4, and mangohud requires 60.0, so we patch it.
+patch -p0 <$CWD/meson594.patch
+
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
@@ -155,6 +156,8 @@ rm -rf $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/graphics/mangohud/mangohud.info b/graphics/mangohud/mangohud.info
index c67b250176..087dc7d59e 100644
--- a/graphics/mangohud/mangohud.info
+++ b/graphics/mangohud/mangohud.info
@@ -1,20 +1,18 @@
PRGNAM="mangohud"
-VERSION="0.6.7.1"
+VERSION="0.6.8"
HOMEPAGE="https://github.com/flightlessmango/MangoHud"
-DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.7-1/MangoHud-0.6.7-1.tar.gz \
+DOWNLOAD="https://github.com/flightlessmango/MangoHud/archive/v0.6.8/MangoHud-0.6.8.tar.gz \
https://github.com/ocornut/imgui/archive/v1.81/imgui-1.81.tar.gz \
https://github.com/mesonbuild/wrapdb/releases/download/imgui_1.81-1/imgui_1.81-1_patch.zip \
https://github.com/gabime/spdlog/archive/v1.8.5/spdlog-1.8.5.tar.gz \
- https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip \
- https://github.com/nlohmann/json/releases/download/v3.10.5/include.zip"
-MD5SUM="61f3a5e392cb08fc1c263ea89781b0d4 \
+ https://github.com/mesonbuild/wrapdb/releases/download/spdlog_1.8.5-1/spdlog_1.8.5-1_patch.zip"
+MD5SUM="414f8b321ec9e548e4f9ebed4f0d645c \
9b48ac38829b538233f99c0aa8cacf50 \
ea266ae77ac14290ceb2eafa56c1de83 \
8755cdbc857794730a022722a66d431a \
- 73a3c3149a4aa2b105aeef3a1d45bcb0 \
- 3cea575f0b559e2609507a5ee6469dea"
+ 73a3c3149a4aa2b105aeef3a1d45bcb0"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="glfw3 %README%"
+REQUIRES="glfw3 nlohmann_json %README%"
MAINTAINER="Steven Voges"
EMAIL="svoges.sbo@gmail.com"
diff --git a/graphics/mangohud/meson594.patch b/graphics/mangohud/meson594.patch
new file mode 100644
index 0000000000..faf9058b65
--- /dev/null
+++ b/graphics/mangohud/meson594.patch
@@ -0,0 +1,11 @@
+--- meson.build 2022-07-31 18:27:11.000000000 -0700
++++ meson.build 2022-08-14 01:07:17.385862414 -0700
+@@ -2,7 +2,7 @@
+ ['c', 'cpp'],
+ version : 'v0.6.8',
+ license : 'MIT',
+- meson_version: '>=0.60.0',
++ meson_version: '>=0.59.4',
+ default_options : ['buildtype=release', 'c_std=c99', 'cpp_std=c++14', 'warning_level=2']
+ )
+
diff --git a/graphics/mangohud/slack-desc b/graphics/mangohud/slack-desc
index 28ac83f9e1..e8c616c788 100644
--- a/graphics/mangohud/slack-desc
+++ b/graphics/mangohud/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-mangohud: mangohud (Vulkan/OpenGL Overlay)
+mangohud: mangohud (Performance Overlay)
mangohud:
mangohud: MangoHud is a Vulkan and OpenGL overlay for monitoring FPS,
mangohud: temperatures, CPU/GPU load and more.