summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author B. Watson2019-12-31 20:45:54 +0100
committer Robby Workman2020-01-03 09:06:15 +0100
commite38cf9f1bce904d466c7f0bfde7f33e247533b1b (patch)
treedf28210109bcbc522e25eb717e38b0af51a1a747 /graphics
parenteeeaebd2f865266d5a947fa40705bd5a4c0d82c0 (diff)
downloadslackbuilds-e38cf9f1bce904d466c7f0bfde7f33e247533b1b.tar.gz
graphics/qiv: Add libopenraw support, fix README+sqf.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/qiv/README34
-rw-r--r--graphics/qiv/new_formats.diff21
-rw-r--r--graphics/qiv/qiv-allfmt.sqf4
-rw-r--r--graphics/qiv/qiv.SlackBuild7
4 files changed, 44 insertions, 22 deletions
diff --git a/graphics/qiv/README b/graphics/qiv/README
index d1151c3910..f8333c67bd 100644
--- a/graphics/qiv/README
+++ b/graphics/qiv/README
@@ -9,23 +9,29 @@ you can use qiv to set your X11-Desktop background.
These formats are supported by default:
-GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS
+GIF TIFF XPM PNG PPM PNM PGM BMP JPEG SVG ICO TGA ICNS WMF[*]
+
+[*] If .wmf files won't load for you, make sure you've updated
+ Slackware recently (e.g. "slackpkg upgrade-all").
Optional supported formats:
-Format | Optional dependenc(y|ies)
------------------------+-----------------------------------------------
-PCX | pcx-pixbuf-loader
------------------------+-----------------------------------------------
-PSD (PhotoShop native) | gdk-pixbuf-psd
------------------------+-----------------------------------------------
-WEBP | libwebp imlib2 webp-pixbuf-loader. Build and
- | install *in that order*.
------------------------+-----------------------------------------------
-WMF (Windows metafile) | wmf-pixbuf-loader
------------------------+-----------------------------------------------
-XCF (Gimp native) | xcf-pixbuf-loader
------------------------+-----------------------------------------------
+Format | Optional dependenc(y|ies)
+------------------------+-----------------------------------------------
+PCX | pcx-pixbuf-loader
+------------------------+-----------------------------------------------
+PSD (PhotoShop native) | gdk-pixbuf-psd
+------------------------+-----------------------------------------------
+WEBP | libwebp imlib2 webp-pixbuf-loader. Build and
+ | install *in that order*.
+------------------------+-----------------------------------------------
+XCF (Gimp native) | xcf-pixbuf-loader
+------------------------+-----------------------------------------------
+RAW (camera images, | libopenraw. Note that only a few raw image
+ various extensions) | formats will actually display with qiv. These
+ | include .crw (Canon), .erf (Epson), and
+ | .nef (Nikon).
+------------------------+-----------------------------------------------
These are runtime dependencies, so they can be installed at any time
without rebuilding qiv.
diff --git a/graphics/qiv/new_formats.diff b/graphics/qiv/new_formats.diff
index 991583586e..bc5622fd89 100644
--- a/graphics/qiv/new_formats.diff
+++ b/graphics/qiv/new_formats.diff
@@ -1,19 +1,19 @@
diff -Naur qiv-2.3.2/Makefile qiv-2.3.2.patched/Makefile
--- qiv-2.3.2/Makefile 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/Makefile 2019-12-27 03:28:13.162355379 -0500
++++ qiv-2.3.2.patched/Makefile 2019-12-31 14:06:51.304388148 -0500
@@ -24,7 +24,7 @@
# skipped.) It should reflect whatever is compiled into imlib.
# The latest version of imlib has removed imagemagick fallback support,
# so some extensions (XBM TGA) have been removed.
-EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO
-+EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA
++EXTNS = GIF TIFF XPM PNG PPM PNM PGM PCX BMP EIM JPEG SVG WMF ICO WEBP XCF PSD ICNS TGA RAW
# Comment this line out if your system doesn't have getopt_long().
GETOPT_LONG = -DHAVE_GETOPT_LONG
diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
--- qiv-2.3.2/main.h 2017-11-03 14:27:27.000000000 -0400
-+++ qiv-2.3.2.patched/main.h 2019-12-27 03:23:02.330241315 -0500
-@@ -199,6 +199,24 @@
++++ qiv-2.3.2.patched/main.h 2019-12-31 14:27:29.455909124 -0500
+@@ -199,6 +199,27 @@
#ifdef EXTN_SVG
".svg",
#endif
@@ -35,10 +35,13 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#ifdef EXTN_JP2
+ ".jp2", ".jpc", ".jpx", ".j2k", ".jpf",
+#endif
++#ifdef EXTN_RAW
++ "dng", "cr2", "crw", "nef", "orf", "pef", "arw", "erf", "mrw", "raf",
++#endif
NULL
};
-@@ -238,6 +256,21 @@
+@@ -238,6 +259,29 @@
#ifdef EXTN_ICO
"MS Windows icon resource",
#endif
@@ -57,6 +60,14 @@ diff -Naur qiv-2.3.2/main.h qiv-2.3.2.patched/main.h
+#ifdef EXTN_JP2
+ "JPEG 2000",
+#endif
++#ifdef EXTN_RAW
++ /* 20191231 bkw: some of these (dng, nef, erf, pef) show up as TIFF
++ with the file command, so we can't include them here. */
++ "Canon CIFF",
++ "Canon CR2",
++ "Olympus ORF",
++ "Minolta Dimage",
++#endif
NULL
};
#endif
diff --git a/graphics/qiv/qiv-allfmt.sqf b/graphics/qiv/qiv-allfmt.sqf
index 872f2bea11..5fa2cb06f6 100644
--- a/graphics/qiv/qiv-allfmt.sqf
+++ b/graphics/qiv/qiv-allfmt.sqf
@@ -1,7 +1,7 @@
+libopenraw
libwebp
-imlib2
webp-pixbuf-loader
-wmf-pixbuf-loader
xcf-pixbuf-loader
gdk-pixbuf-psd
pcx-pixbuf-loader
+imlib2
diff --git a/graphics/qiv/qiv.SlackBuild b/graphics/qiv/qiv.SlackBuild
index 08aaea2aa1..0320a81708 100644
--- a/graphics/qiv/qiv.SlackBuild
+++ b/graphics/qiv/qiv.SlackBuild
@@ -8,6 +8,11 @@
# version had no license, modified version released under the WTFPL. See
# http://www.wtfpl.net/txt/copying/ for details.
+# 20191231 bkw:
+# - Add libopenraw (raw camera image) formats, BUILD=2.
+# - Remove mention of wmf-pixbuf loader from README and .sqf
+# since there's a Slackware update that removes the need for it.
+
# 20191226 bkw:
# - Upgrade for v2.3.2. This was released a month after my last update,
# but the download page on the site doesn't link to it (found it just
@@ -26,7 +31,7 @@
PRGNAM=qiv
VERSION=${VERSION:-2.3.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then