summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2017-07-05 04:11:28 +0200
committer Willy Sudiarto Raharjo2017-07-05 04:11:28 +0200
commitcc0cfeb3939487923509541e178c27711dfe1d56 (patch)
tree54cbaa208127049756e88126f533e23bbb0e3ff3 /graphics
parent11872f9f213da332718dd9a948ef855bd6ffcfeb (diff)
downloadslackbuilds-cc0cfeb3939487923509541e178c27711dfe1d56.tar.gz
graphics/exact-image: Fix build on -current.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/exact-image/c98.patch12
-rw-r--r--graphics/exact-image/exact-image.SlackBuild5
-rw-r--r--graphics/exact-image/raw.patch11
3 files changed, 27 insertions, 1 deletions
diff --git a/graphics/exact-image/c98.patch b/graphics/exact-image/c98.patch
new file mode 100644
index 0000000000..2c8d42a285
--- /dev/null
+++ b/graphics/exact-image/c98.patch
@@ -0,0 +1,12 @@
+--- exact-image-0.9.2/Makefile.orig 2016-12-12 09:23:11.937243882 +0000
++++ exact-image-0.9.2/Makefile 2016-12-12 09:27:03.967245907 +0000
+@@ -48,7 +48,7 @@
+ # we have some unimplemented colorspaces in the Image::iterator :-(
+ CFLAGS += $(call cc-option,-Wno-switch -Wno-switch-enum,)
+
+-CXXFLAGS := $(CFLAGS) -Wno-sign-compare
++CXXFLAGS := $(CFLAGS) -Wno-sign-compare -std=gnu++98
+
+ ifeq "$(STATIC)" "1"
+ X_EXEFLAGS += -static
+
diff --git a/graphics/exact-image/exact-image.SlackBuild b/graphics/exact-image/exact-image.SlackBuild
index 790c5c8631..062349e00f 100644
--- a/graphics/exact-image/exact-image.SlackBuild
+++ b/graphics/exact-image/exact-image.SlackBuild
@@ -56,12 +56,15 @@ sed "s,@vendorlib@,$vendorlib,g" $CWD/fixup-perl_paths.diff | patch -p1 --verbos
# Fix for swig-3.0.7
sed -i -e '/^# manually/d' api/api-swig.hh
+patch -p1 < $CWD/c98.patch
+patch -p1 < $CWD/raw.patch
+
./configure \
--bindir=/usr/bin \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--without-php
-make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
+make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS -Wno-narrowing -fpermissive"
make install DESTDIR=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/graphics/exact-image/raw.patch b/graphics/exact-image/raw.patch
new file mode 100644
index 0000000000..555fef4fc1
--- /dev/null
+++ b/graphics/exact-image/raw.patch
@@ -0,0 +1,11 @@
+--- exact-image-0.9.2/codecs/raw.cc.orig 2017-07-05 09:07:52.988538841 +0700
++++ exact-image-0.9.2/codecs/raw.cc 2017-07-05 09:08:21.813539168 +0700
+@@ -71,7 +71,7 @@
+ if (!image.getRawData())
+ return false;
+
+- return stream->write ((char*)image.getRawData(), image.stride()*image.h)
++ return (bool) stream->write ((char*)image.getRawData(), image.stride()*image.h)
+ /* ==
+ (size_t) image.stride()*image.h*/;
+ }