summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2012-04-06 16:40:06 +0200
committer Erik Hanson2012-04-09 18:53:24 +0200
commit6bfcec9d9ac7e06b5b90e41c9ecda53c14206868 (patch)
treed6508a172f563f2dc934456be6093ca2a63b0a69 /graphics
parentdc5f6f416d91f5d8266f892a5dd1d7491db9542e (diff)
downloadslackbuilds-6bfcec9d9ac7e06b5b90e41c9ecda53c14206868.tar.gz
graphics/exact-image: Updated for version 0.8.7.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/exact-image/README17
-rw-r--r--graphics/exact-image/exact-image.SlackBuild2
-rw-r--r--graphics/exact-image/exact-image.info8
-rw-r--r--graphics/exact-image/fixup-perl_paths.diff6
-rw-r--r--graphics/exact-image/png.cc-libpng14.diff6
5 files changed, 20 insertions, 19 deletions
diff --git a/graphics/exact-image/README b/graphics/exact-image/README
index 462851f603..eba5d60d42 100644
--- a/graphics/exact-image/README
+++ b/graphics/exact-image/README
@@ -1,11 +1,12 @@
-ExactImage is an image processing library which reimplements
+ExactImage is an image processing library which reimplements
ImageMagick functions with a significant speed improvement.
The library also provides several new algorithms: lossless JPEG
-transforms and creation of searchable PDFs from hOCR annotated HTML
-created with an OCR program such as Tesseract or Cuneiform (available
-at Slackbuilds.org). There are bindings for PHP, Lua, Perl, and Python.
-See /usr/doc/exact-image-*/examples/ for information on using exactimage
-with Perl, Python, PHP and Lua.
+transforms and creation of searchable PDFs from hOCR annotated
+HTML created with an OCR program such as Tesseract or Cuneiform
+(available at Slackbuilds.org). There are bindings for PHP, Lua,
+Perl, and Python. See /usr/doc/exact-image-*/examples/ for
+information on using exactimage with Perl, Python, PHP and Lua.
-ExactImage requires agg. Lua and evas are optional dependencies available
-at Slackbuilds.org, while bardecode is optional but not available.
+ExactImage requires agg. lua and evas are optional dependencies
+(both available here at Slackbuilds.org) while bardecode is also
+optional but not available here.
diff --git a/graphics/exact-image/exact-image.SlackBuild b/graphics/exact-image/exact-image.SlackBuild
index 2820020bdf..f124ced6cb 100644
--- a/graphics/exact-image/exact-image.SlackBuild
+++ b/graphics/exact-image/exact-image.SlackBuild
@@ -3,7 +3,7 @@
# Written by Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
PRGNAM=exact-image
-VERSION=${VERSION:-0.8.6}
+VERSION=${VERSION:-0.8.7}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/graphics/exact-image/exact-image.info b/graphics/exact-image/exact-image.info
index e04eb8fa2a..cdad5b7c44 100644
--- a/graphics/exact-image/exact-image.info
+++ b/graphics/exact-image/exact-image.info
@@ -1,10 +1,10 @@
PRGNAM="exact-image"
-VERSION="0.8.6"
+VERSION="0.8.7"
HOMEPAGE="http://www.exactcode.de/site/open_source/exactimage/"
-DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.6.tar.bz2"
-MD5SUM="605f19bc33d2bcc49a39e72a181ba137"
+DOWNLOAD="http://dl.exactcode.de/oss/exact-image/exact-image-0.8.7.tar.bz2"
+MD5SUM="4469fada7792356749a6b0c356aa4931"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Benjamin Trigona-Harany"
EMAIL="bosth@alumni.sfu.ca"
-APPROVED="Erik Hanson,Niels Horn"
+APPROVED="rworkman"
diff --git a/graphics/exact-image/fixup-perl_paths.diff b/graphics/exact-image/fixup-perl_paths.diff
index 475e417462..a0d6589bf9 100644
--- a/graphics/exact-image/fixup-perl_paths.diff
+++ b/graphics/exact-image/fixup-perl_paths.diff
@@ -1,6 +1,6 @@
-diff -Nur exact-image-0.8.3.orig//api/perl/Makefile exact-image-0.8.3/api/perl/Makefile
---- exact-image-0.8.3.orig//api/perl/Makefile
-+++ exact-image-0.8.3/api/perl/Makefile
+diff -Nur exact-image-0.8.7.orig//api/perl/Makefile exact-image-0.8.7/api/perl/Makefile
+--- exact-image-0.8.7.orig//api/perl/Makefile
++++ exact-image-0.8.7/api/perl/Makefile
@@ -20,5 +20,6 @@
all:: $($(X_MODULE)_BINARY)
install:: $($(X_MODULE)_BINARY)
diff --git a/graphics/exact-image/png.cc-libpng14.diff b/graphics/exact-image/png.cc-libpng14.diff
index 2f59c43b96..ca738dbcf5 100644
--- a/graphics/exact-image/png.cc-libpng14.diff
+++ b/graphics/exact-image/png.cc-libpng14.diff
@@ -1,6 +1,6 @@
-diff -Naur exact-image-0.8.3-old/codecs/png.cc exact-image-0.8.3/codecs/png.cc
---- exact-image-0.8.3-old/codecs/png.cc
-+++ exact-image-0.8.3/codecs/png.cc
+diff -Naur exact-image-0.8.7-old/codecs/png.cc exact-image-0.8.7/codecs/png.cc
+--- exact-image-0.8.7-old/codecs/png.cc
++++ exact-image-0.8.7/codecs/png.cc
@@ -71,7 +71,7 @@
/* Allocate/initialize the memory for image information. REQUIRED. */
info_ptr = png_create_info_struct(png_ptr);