summaryrefslogtreecommitdiffstats
path: root/graphics/shaderc/shaderc.SlackBuild
diff options
context:
space:
mode:
author orbea2020-06-08 19:51:18 +0200
committer Willy Sudiarto Raharjo2020-06-14 12:45:53 +0200
commit67556053da3e27693c1e43afa99e6ed4a5363898 (patch)
treef531ceca0de7de8a304d98ce609d4895a2dfc24d /graphics/shaderc/shaderc.SlackBuild
parentc74ea54aa60321b6e11fb12bde9c6c484bc95742 (diff)
downloadslackbuilds-67556053da3e27693c1e43afa99e6ed4a5363898.tar.gz
graphics/shaderc: Updated for version 2020.0.
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/shaderc/shaderc.SlackBuild')
-rw-r--r--graphics/shaderc/shaderc.SlackBuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/shaderc/shaderc.SlackBuild b/graphics/shaderc/shaderc.SlackBuild
index 7c39dc871f..0bed4b6f4d 100644
--- a/graphics/shaderc/shaderc.SlackBuild
+++ b/graphics/shaderc/shaderc.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=shaderc
-VERSION=${VERSION:-2019.1}
+VERSION=${VERSION:-2020.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -73,6 +73,9 @@ find -L . \
sed -i '/examples/d;/third_party/d' CMakeLists.txt
sed -i '/build-version/d' glslc/CMakeLists.txt
+# Use the system install path for spirv.hpp
+sed -i 's|spirv/unified1/spirv.hpp|SPIRV/spirv.hpp|' libshaderc/src/shaderc.cc
+
glslang_version="$(glslangValidator -v | grep 'Glslang Version')"
# Create build-version.inc since git versioning is disabled.
@@ -83,6 +86,12 @@ cat > glslc/src/build-version.inc <<EOF
"glslang-${glslang_version##* }\\n"
EOF
+# Fix build
+# https://github.com/google/shaderc/issues/1056
+# https://github.com/google/shaderc/pull/1057
+# https://github.com/google/shaderc/commit/15a66d72f33a099ec65e0fd37cf14548ed1d2bdb
+patch -p1 < $CWD/build.patch
+
# Fix the link order of libglslang and libHLS
# https://github.com/google/shaderc/pull/463
patch -p1 < $CWD/fix-glslang-link-order.patch