summaryrefslogtreecommitdiffstats
path: root/graphics/rawstudio/rawstudio.SlackBuild
diff options
context:
space:
mode:
author Nishant Limbachia2015-08-14 02:27:44 +0200
committer Willy Sudiarto Raharjo2015-08-14 02:27:44 +0200
commit957e31fc8bf8564778273e5ef1f1ffa1d51274d7 (patch)
treef66c7c80b4a1e04ce8eaf2241038a9cea633ef97 /graphics/rawstudio/rawstudio.SlackBuild
parentff90c899636cb42b9e67d3ee8288518f17db0238 (diff)
downloadslackbuilds-957e31fc8bf8564778273e5ef1f1ffa1d51274d7.tar.gz
graphics/rawstudio: Patched for newer lensfun.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics/rawstudio/rawstudio.SlackBuild')
-rw-r--r--graphics/rawstudio/rawstudio.SlackBuild28
1 files changed, 20 insertions, 8 deletions
diff --git a/graphics/rawstudio/rawstudio.SlackBuild b/graphics/rawstudio/rawstudio.SlackBuild
index 38abc69ae6..3c16761bc7 100644
--- a/graphics/rawstudio/rawstudio.SlackBuild
+++ b/graphics/rawstudio/rawstudio.SlackBuild
@@ -3,7 +3,8 @@
# Slackware Package Build Script for rawstudio
# Home Page http://rawstudio.org/
-# Copyright (c) 2007-2011, Nishant Limbachia, Hoffman Estates, IL, USA (nishant _AT_ mnspace _DOT_ net)
+# Copyright (c) 2007-2015, Nishant Limbachia, Hoffman Estates, IL, USA
+# (nishant _AT_ mnspace _DOT_ net)
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -29,7 +30,7 @@
PRGNAM="rawstudio"
VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,19 +65,29 @@ set -e
rm -fr $TMP/$PRGNAM-$VERSION $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
cd $PRGNAM-$VERSION
chown -R root.root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Add libgthread-2.0.so to linked-in library list
find . -name "Makefile.in" -exec \
sed -i "s,@PACKAGE_LIBS@,@PACKAGE_LIBS@ -lgthread-2.0,g" {} \;
+# Patches shamelessly copied from Arch Linux PKGBUILD:
+# https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/rawstudio
+
+# Patch to use lensfun > 0.3
+patch -p1 < $CWD/patches/lensfun03.patch
+
+# Patch to use libpng > 1.5. This patch is only useful on -current and will need to
+# be applied once -current releases. Uncomment if you are building on -current
+#patch -p1 < $CWD/patches/libpng15.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -85,12 +96,13 @@ CXXFLAGS="$SLKCFLAGS" \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--localstatedir=/var \
--mandir=/usr/man \
+ --enable-static=no \
--build=$ARCH-slackware-linux
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION